1

Some background: On the site I'm maintaining, I installed Internationalization module and also enabled Node Translation. I added a few languages, then set a node's language to French and site default language to English.

When the site's current language is set to French, the node shows up as en/node/28, however shows up as fr/sous-specialites when the current language is French. How do I work this around?

UPDATE: Detection and Selection page has URL, Session, User and Browser enabled.

0

I guess you want the url alias to be /sous-specialites for the english node. If so, I think you can use Global redirect module.

From the documentation,

What?

GlobalRedirect is a simple module which…

  • Checks the current URL for an alias and does a 301 redirect to it if it is not being used.
  • Checks the current URL for a trailing slash, removes it if present and repeats check 1 with the new request.
  • Checks if the current URL is the same as the site_frontpage and redirects to the frontpage if there is a match.
  • Checks if the Clean URLs feature is enabled and then checks the current URL is being accessed using the clean method rather than the 'unclean' method.
  • Checks access to the URL. If the user does not have access to the path, then no redirects are done. This helps avoid exposing private aliased node's.
  • Make sure the case of the URL being accessed is the same as the one set by the author/administrator. For example, if you set the alias "articles/cake-making" to node/123, then the user can access the alias with any combination of case.
  • Most of the above options are configurable in the settings page. In Drupal 5 you can access this after enabling the globalredirect_admin module. In Drupal 6, the settings page is bundled into the module.
0

Option 1:

The order specified at Configuration -> Languages -> detection and selection could be what explains the current behaviour in your site.

You'd have to experiment a bit with what the exact order in your case should be. But in my experience, I often get these kind of issues to work by using an order like "URL, Default, User", and not something like "Default, URL, User". So try to experiment a bit with the various combinations in this order to check if it helps.

Option 2:

Another reason why such issue / problem may occur, is because Language detection by domain only works on port 80 and/or URL generation only works on port 80. Those issues have 'some patches' attached to it, and status = Needs review.

So if you're not using port 80, then you may want to try/consider experimenting with any of the patches in these issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.