2

I created a Feeds Importer for commerce products. One such product is an album which contains multiple mp3 files. So in the files field of the content type, this is set to unlimited.

but my feeds importer isn’t accepting multiple values. Ive tried using the the pipe char (|) but it’s not working.

my CSV looks like this. fyi - having one commerce mp3 file reference in the csv does work. but when adding another and separating w/ the pipe symbol, it does not.

How can this be achieved?

my csv file so far -

SKU,Title,Album cover front,Price,Files
SKU_ALB#8_CD_SOME_TITLE,http://staging.MYSITE.com/feeds/album_artwork/cd_cover_front.jpg,1000,private://albums/Killer Track.mp3|private://albums/Heavy Groove.mp3
3

Have a look at feeds tamper.

Using the pipe symbol is alright. The next step would be to enable Feeds Tamper and chose to "Explode" the "Files" with the pipe character as separator.

2

You need to use Feeds Tamper to take a single value and make it into an array. Examples: multiple columns to a single, multi-valued field or a whole node importer using it.

tl;dr - You're looking for the "explode" tamper plugin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.