0

I'm using Drupal 7 with the Domain Access module version 7.x-311. I've successfully configured a bunch of subdomains running sites correctly, with one subdomain as default.

All worked well until I swapped out the default domain with a new one. Now, every login attempt for admin including user 1 hits an 'access denied'.

I've updated the domain access settings to set the new domain as default. I've also ensured that the default domain is not set in the settings.php file, plus set the domain cookies settings reflects the top-level domain.

I've also cleared cache and cleared browser cache and cookies, still I get an access denied. I cannot work it out.

Has anyone got advice on where to look next?

N

  • Hey @travis-johnston - thanks for the reply. I've cleared the session table as you suggested, and still no luck. There's no heavy caching in affect in this instance. – Neil Phillips Jan 13 '16 at 21:44
0

Caching would be my first thought, make sure to clear cache (through drush since you can't log in). Also if you have any heavy caching like Varnish - clear that too. You may have an active session still in Drupal for the admin account, try removing that via - drush sql-query 'TRUNCATE TABLE sessions;'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.