1

I bought a premium theme, installed it, and the site crashed with a WSOD, so I figured changing the theme back to Bartik would probably solve it. Thus, after reading the very fresh Drush 8 documentation I ran the command (also tried other variations that didn't work):

drush config-set system.theme default bartik

Yet, when I did that I got the same error I had before I moved the Dev environment from Windows10 to Ubuntu, that very same error "the demon who haunted me" that says (paraphrase): "Please use a more functional environment for bootstrapping Drush"... I mean, even Ubuntu isn't? Come on...


System details: Ubuntu desktop 15.10, apache 2.4.12, php 5.6.11, mysql 5.6.27... full session:

enter image description here

1

I wasn't inside the sites' folder! I didn't notice that for some reason - Here is a possible explanation why, that might be nice for you to read:

In the similar time period, I also ran a few general Drush commands inside the root folder just to check if Drush itself is working because of Environment Variable (Path) value setting mistakes I made earlier and tried to fix; I could run drush in each session only after manual var export, but I than went to home/.profile, and added export PATH="~/.composer/vendor/bin:$PATH" in the end of file and it fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.