0

I have a site with ckeditor 7.x-1.16 installed (not the WYSIWYG module). I have a local dev (XAMPP windows) staging (Linux) and production (Linux).

On the local dev copy and the production copy ckeditor isn't showing on the edit body tag. Missing ckeditor on the edit body tag and shows 403 errors

In firebug net tab ckeditor.config.js and ckeditor.styles.js are showing as 403 - forbidden.

I have tried replacing my local copy of the ckeditor module and the ckeditor library with the ones from the staging server where ckeditor is working. This does not fix my dev copy.

I have tried upgrading to ckeditor 7.x-1.17. I have tried a new install of 7.x-1.16. I have tried deleting the ckeditor library and downloading a fresh version. I have tried moving the library files to the alternative location within ckeditor. I have tried to increase the permissions in windows of the ckeditor module (I believe windows doesn't have chmod). I have also tried chmod 755 on the module files on the production site. None of these has helped.

ADDITION: I have have made a new local version of the Staging server version (where the problem doesn't occur). The problem is on the fresh local copy, despite it having the same files and db as the staging version.

  • I haven't used Windows in a while but I don't think perms come into it on that platform, so that probably points to an issue with web server config. Check your vhost/.htaccess for custom rules that might be interfering - the fact that both files are foo.bar.js might be interesting, there could be a rule denying access to files matching that pattern for example – Clive Jan 14 '16 at 18:05
  • Thanks. I looked in xampp/apache/conf/extra/httpd-vhosts.conf but this was all commented out. There I checked my main .htaccess and didn't see anything there either. Any other ideas? – Paul Trotter Jan 15 '16 at 11:19
0

I worked this out. I found an .htaccess 'deny from all' file in the sites/all/modules directory. It must have accidentally got copied in there from the sites/all/files/private directory. I removed the file and ckeditor shows fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.