1

I've adding and removing modules with drush when something went wrong. I'm using the latest version of Acquia devdesktop and now when I run any drush command I get the error "the file name, directory name, or volume label syntax is incorrect." This error seems to be specific to the site I am working on, as drush works outside of the site folder. How can I fix this?

UPDATE: so, I deleted what I thought were the offending folders but the problem persists.

Update2: ran the drush debug command and I didn't see anything meaningful or diagnostic in the results.

Starting Drush preflight. [0.21 sec, 1.68 MB]                        [preflight]
Loading drushrc "C:\Program Files\Dev                                [bootstrap]
Desktop\drush\vendor\drush\drush\drushrc.php" into "drush" scope.
[0.22 sec, 1.69 MB]
Cache MISS cid:                                                          [debug]
8.0.0-rc1-commandfiles-0-d122bbeed82161c117b94e5f9e65d6f6 [0.33 sec,
1.72 MB]
Cache SET cid:                                                           [debug]
8.0.0-rc1-commandfiles-0-d122bbeed82161c117b94e5f9e65d6f6 [0.41 sec,
1.74 MB]
Scanning into C:\ProgramData/Drush/etc/drush for                     [sitealias]
/.*aliases\.drush(8|)rc\.php$/ [0.51 sec, 3.41 MB]
Scanning into C:\ProgramData/Drush/etc/drush for                     [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [0.51 sec, 3.41 MB]
Scanning into C:\Program Files\Dev                                   [sitealias]
Desktop\drush\vendor\drush\drush\includes/.. for
/.*aliases\.drush(8|)rc\.php$/ [0.52 sec, 3.41 MB]
Scanning into C:\Program Files\Dev                                   [sitealias]
Desktop\drush\vendor\drush\drush\includes/.. for
/self\.alias\.drush(8|)rc\.php$/ [0.62 sec, 3.42 MB]
Scanning into C:\Users\Nick/.drush for /.*aliases\.drush(8|)rc\.php$/[sitealias
[0.71 sec, 3.42 MB]
Scanning into C:\Users\Nick/.drush for                               [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [0.71 sec, 3.42 MB]
Scanning into C:\Users\Nick/.acquia/DevDesktop/Drush/Aliases for     [sitealias]
/.*aliases\.drush(8|)rc\.php$/ [0.72 sec, 3.42 MB]
Scanning into C:\Users\Nick/.acquia/DevDesktop/Drush/Aliases for     [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [0.72 sec, 3.42 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/../drush for        [sitealias]
/.*aliases\.drush(8|)rc\.php$/ [0.72 sec, 3.42 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/../drush for        [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [0.72 sec, 3.42 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/drush for           [sitealias]
/.*aliases\.drush(8|)rc\.php$/ [0.73 sec, 3.42 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/drush for           [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [0.73 sec, 3.42 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/sites/all/drush for [sitealias]
/.*aliases\.drush(8|)rc\.php$/ [0.73 sec, 3.42 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/sites/all/drush for [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [0.73 sec, 3.42 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/sites/default for   [sitealias]
/.*aliases\.drush(8|)rc\.php$/ [0.73 sec, 3.42 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/sites/default for   [sitealias]

/self\.alias\.drush(8|)rc\.php$/ [0.73 sec, 3.43 MB]
Begin redispatch via drush_invoke_process(). [1.32 sec, 5.17 MB]        [notice]
Scanning into C:\ProgramData/Drush/etc/drush for                     [sitealias]
/.*aliases\.drush(8|)rc\.php$/ [1.32 sec, 5.17 MB]
Scanning into C:\ProgramData/Drush/etc/drush for                     [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [1.33 sec, 5.17 MB]
Scanning into C:\Program Files\Dev                                   [sitealias]
Desktop\drush\vendor\drush\drush\includes/.. for
/.*aliases\.drush(8|)rc\.php$/ [1.33 sec, 5.17 MB]
Scanning into C:\Program Files\Dev                                   [sitealias]
Desktop\drush\vendor\drush\drush\includes/.. for
/self\.alias\.drush(8|)rc\.php$/ [1.41 sec, 5.17 MB]
Scanning into C:\Users\Nick/.drush for /.*aliases\.drush(8|)rc\.php$/[sitealias]
[1.5 sec, 5.17 MB]
Scanning into C:\Users\Nick/.drush for                               [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [1.5 sec, 5.17 MB]
Scanning into C:\Users\Nick/.acquia/DevDesktop/Drush/Aliases for     [sitealias]
/.*aliases\.drush(8|)rc\.php$/ [1.5 sec, 5.18 MB]
Scanning into C:\Users\Nick/.acquia/DevDesktop/Drush/Aliases for     [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [1.51 sec, 5.18 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/../drush for        [sitealias]
/.*aliases\.drush(8|)rc\.php$/ [1.51 sec, 5.18 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/../drush for        [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [1.51 sec, 5.18 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/drush for           [sitealias]
/.*aliases\.drush(8|)rc\.php$/ [1.51 sec, 5.18 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/drush for           [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [1.51 sec, 5.18 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/sites/all/drush for [sitealias]
/.*aliases\.drush(8|)rc\.php$/ [1.52 sec, 5.18 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/sites/all/drush for [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [1.52 sec, 5.18 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/sites/default for   [sitealias] 
/.*aliases\.drush(8|)rc\.php$/ [1.52 sec, 5.18 MB]
Scanning into C:\Users\Nick\Sites\devdesktop\psr/sites/default for   [sitealias]
/self\.alias\.drush(8|)rc\.php$/ [1.52 sec, 5.18 MB]
Backend invoke: "C:\\Users\\Nick\\Sites\\devdesktop\\psr\\drush"       [command]
--root="C:\\Users\\Nick\\Sites\\devdesktop\\psr" --local --debug
--verbose  core-status 2>&1 [1.53 sec, 5.19 MB]
Calling proc_open("C:\\Users\\Nick\\Sites\\devdesktop\\psr\\drush"  --root="C:\\
Users\\Nick\\Sites\\devdesktop\\psr" --local --debug --verbose  core-status 2>&1
);
The filename, directory name, or volume label syntax is incorrect.
End redispatch via drush_invoke_process(). [1.55 sec, 5.18 MB]          [notice]
1

This error just happen to me.

Not sure about how to fix this error. But for workaround, I install drush via composer and use that Drush. Not the one installed from Acquia Dev Desktop.

Because I use Drupal Comoposer project template, this is the command I run:

D:\Sites\myweb\web>..\vendor\bin\drush.bat cr --root="D:\\Sites\\myweb\\web"
Cache rebuild complete.    
1

I had the same error in a new Drupal project which installed drush (8.1.8) for that project via composer (inside the project/vendor folder).

The command 'drush status' showed that I was using an older, global installed version of drush (inside C:\Users\Gebruiker\AppData\Roaming\Composer\vendor\drush\drush).

I edited my environment variables, edited the PATH variable, and changed the global drush path to my projects drush path. Then closed all command windows and my IDE and reopened my IDE and project.

The command drush status now showed the correct drush version (8.1.8) and all drush commands are now working fine.

0

Hopefully, you should be able to discover which file/directory name is causing the problem, by making Drush print some debugging info:

drush -d -d status
  • tried it, posted the results above, didn't see something that was meaningful – nizz0k Jan 22 '16 at 12:11
  • Well, does C:\Users\Nick\Sites\devdesktop\psr\drush exist? I'm running Acquia Dev Desktop myself and don't get the same debug info as you. Some questions: 1) Are you sure you run the latest Acquia Dev Desktop (ADD)? It seems you are running Drush 8.0.0-rc1 while the latest version of ADD has Drush 8.0.0. 2) Which version of Drupal are you using? 3) Have you installed Drush manually in addition to the Drush coming with ADD? 4) Have you created an (alias) drushrc.php file yourself? – hansfn Jan 23 '16 at 16:36
  • there's no drush folder in the site route, and there usually aren't in my ADD sites.. Yes, it's the 8.0.0-rc1 version of drush. I assume it's the latest ADD since it hasn't been bugging me for an update It's version 7.41 of drupal. Yes, I have a manual install of drush, in addition the ADD version.I haven't created a drush alias. – nizz0k Jan 23 '16 at 18:00
  • ADD didn't bug me with an update notice - I checked myself using "Check for updates" in the menu ... How about removing the manually installed drush to track down the problem. – hansfn Jan 28 '16 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.