0

I've exported a feature that contains a rule —

// my_feature.info
features[rules_config][] = rules_my_rule

// my_feature.rules_defaults.inc
$items['rules_my_rule'] = entity_import('rules_config', '{ "rules_my_rule" : {
   ...
  }');

When I modify the rule with Rules UI, I'd expect the feature to be marked as overridden, but it's not. I've tried disabling a rule and editing a rule's conditions. Neither change affects the feature's status (Default).

I've tried clearing all caches (drush cc all) and reinstalling the feature (drush dre my_feature).

Am I missing some step needed to make features detect changes to rules?

Edit: If I update the feature (even though it doesn't say "overridden"), the changes to get written to my_feature.rules_defaults.inc. But reverting the feature (even with drush fr --force) has no effect.

0

Rules UI shows the rule as "overridden". If I click "revert" on that page, the rule reverts to the state saved in my_feature.rules_defaults.inc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy