0

Problem

I created a clean VM & installed COD. Unfortunately, when people aren't logged in they see: error

How should I go about diagnosing further and/or resolving this issue?

Things tried

  • I thought this might be because the first conference wasn't published but the published flag was set, and I ticked the 'Promoted to front page' option.
  • That did not resolve the issue, so I created a basic page and applied the same options. No change to the homepage.
  • The homepage was set to node/1 so I changed it to no extension so that it could use the default homepage. No change.
  • UPDATE: Ticked Grant content access and Grant own content access for anonymous users in admin/people/permissions
  • UPDATE: Tried to use the rebuild option (/admin/reports/status/rebuild) to no avail
  • 1
    Check the permissions for "access content" - do the right roles have that enabled? If so, check what content access module you have installed (if any), and how they're configured – Clive Jan 26 '16 at 13:59
  • For Content Access - these were unticked. I presume the "and modify" bit has less control than it suggests? Grant content access: View and modify content access for any nodes anonymous user Grant own content access: View and modify content access for own nodes – Steph Locke Jan 26 '16 at 14:03
  • @Clive - I ticked the two options (in admin/people/permissions), logged out, no joy – Steph Locke Jan 26 '16 at 14:05
  • Oh so you actually have the "Content Access" module installed and enabled? That's probably the problem, that module doesn't exist on a fresh install of Drupal (where I've never seen the issue you're describing before). Whatever installation profile you've used has probably messed something up, contacting the developer would probably be the best move – Clive Jan 26 '16 at 14:11
0

The permission required is View published content.

It turns out the content access module has a lot of different permissions that can be assigned to roles and this one is not selected by default for anonymous users.

This is a really easy permission to miss. It sits deep within nodes permissions and if you use the search facility for words like view or access you won't get it in the search result. Heck, if you search View published content it isn't returned.

  • For next time, this module makes administering perms a bit easier – Clive Jan 26 '16 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.