3

I have made a stupid mistake:

I installed the .po for another language and set it as default (instead of English) even though I did not install/configure all the prerequisites. Now, each time I try to access my website, it goes into an endless loop and I can no longer access its configuration panels.

How can I reset the default language back to English? Is there any file to configure or database entry to change?

8

In the setting.php file used by your site, add the following lines:

$conf['language_default'] = (object) array(
  'language' => 'en', 'name' => 'English', 'native' => 'English',
  'direction' => 0, 'enabled' => 1, 'plurals' => 0, 'formula' => '',
  'domain' => '', 'prefix' => '', 'weight' => 0, 'javascript' => ''
);

This will force Drupal to use English as default language. Once you removed the language files for that language, remove those lines from the settings.php file, or Drupal will always use English as default language, indifferently from what you set from the setting page.

The same trick works also for Drupal 6.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.