0

After two clean installs of Drupal 8.0.2 without issues on my server (Debian 7.1 / PHP 5.6.17 / MySQL 5.5.31) I can log in and out fine and view my user profile page, but that's it.

Any /admin/* pages returns the following error:

The website encountered an unexpected error. Please try again later.

I'm a little stuck as effectively I can't do anything and this wasn't an issue locally on WAMP. Can someone offer me guidance please? I've had a look for error logs on the server but unless I'm looking in the wrong places I'm not seeing anything.

Database watchdog shows the following error. (The serialized array has been edited to show the relevant parts.)

GuzzleHttp requires cURL, the allow_url_fopen ini setting, or a custom HTTP handler.
GuzzleHttp\choose_handler()
/var/www/virtual/mysite.info/drupaltest/htdocs/vendor/guzzlehttp/guzzle/src/functions.php"; line 116

As suggested in other similar posts I have tried increasing max_allowed_packet.

  • 2
    Welcome to Drupal Answers :) I'm afraid we can't help to debug your site from here without more info, but it should be easy enough to get at the real error - check the variables column in the watchdog table, it'll have the replacements for @message, %function, %line and %file. Once you've got those edit them into the question and it'll be a lot easier to point you in the right direction – Clive Jan 28 '16 at 18:11
  • 2
    No worries - you're just missing cURL, sudo apt-get install php5-curl and a web server restart ought to fix it – Clive Jan 28 '16 at 20:06
  • 1
    Thanks so much dude! You should post this as an answer so I can give you your dues ;) – Matthew E Cornish Jan 28 '16 at 20:33
  • @MatthewECornish I think Clive has enough points as it is. You can post the answer yourself and thank him there ☺. – Eyal Jan 29 '16 at 7:00
  • make sure your $settings['rebuild_access'] = TRUE; in your settings and try pointing your browser to: example.com/core/rebuild.php – pjcarly Jan 29 '16 at 16:45
0

Just to get this marked off as answered (with thanks to Clive).

First of all was understanding how to make use of the database watchdog table to find the errors. You have to download and view the variables column... the error's in there. In my case it was that cURL was not installed.

It was as simple as installing cURL and restarting the Apache service.

apt-get install php5-curl

Thanks again to Clive!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.