1

I am trying to make changes to a saved "selection rule" on one of my Panels, but when I click the settings gear icon, the icon moves on top of the "Delete" icon for a second, then moves back alongside - but no modal pops up.

Tried: - disabling javascript in browser (results in a page of code after clicking gear) - Using a different browser

  • Checked status page for errors
  • Switching versions of jQuery (via jQ update) as well as source CDN
  • Clearing caches
  • Restarting httpd
  • Testing it on my dev server with a similar environment - works fine
  • Tried the same operation in another Drupal installation on the same server, and the same modal works fine with that one.

The site is on a Centos 6 VPS running CPanel, APC and memcached, and behind Varnish.

I see nothing related in /var/log/messages, domlogs, error logs or watchdog, nor in the console.

When a Panels modal works (e.g. clicking the gear icon for a rule in the Context section of the same Panel) the console shows "Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check http://xhr.spec.whatwg.org/." But on the site where it works, this message doesn't show up in the console. This is the closest thing to a clue I've been able to find, but I don't know what it means.

Any suggestions how to fix it, or even how to diagnose what the problem is?

1

Figured it out. I was using Adminimal for my admin theme, and I changed the skin to "Alternative" and tried again ... and it worked. So it was something in the theme that caused the conflict, though I don't know what.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.