0

Currently I'm working on a 6-language website and all content obviously needs to be translated, including menus. For this, I have enabled i18n_menu and i18n_select (as I had a little experience on the latter regarding this issue), translated the originally French node to English, and both menu items show up when I go to English translation of the node. Any ideas?

There are several discussions on drupal.SO about this, including this and this one on drupal.org; but none seemed to resolve my issue.

my screenshot for the issue

1 Answer 1

0

I suppose you added the french menu item before you added additional languages to your Drupal. Then it is very likely that it was saved using LANGUAGE_NEUTRAL as language and therefore will appear within all languages.

To fix this, go to the menu's item list on admin/structure and manually edit the menu item. You should find a drop down for the language within the edit form. Make sure to choose the appropriate language here and save the item.

5
  • All the menu items say "Undefined. This menu item belongs to a node, so it will have the same language as the node and cannot be localized." for the language and I'm not allowed to change, if that's what you mean.
    – Kartagis
    Jan 29, 2016 at 19:31
  • For further assistance, I'd like to make sure: You did enable menu translation as well within the "Edit Menu" page? Which option did you choose there? And which kind of translation do you use for your nodes? Node translation (the internationalisation module only) or entity (field) translation? Jan 30, 2016 at 0:50
  • I enabled menu translation in /admin/modules, and I chose Translate and Localize. Menu items with language will allow translations. Menu items without language will be localized. from the menu's edit link
    – Kartagis
    Jan 30, 2016 at 9:03
  • And for node translation? (I'm just trying to reproduce your settings.) Jan 30, 2016 at 12:21
  • I have Extended, but not displayed - All defined languages will be allowed for input, but not displayed in links. for multilingual settings.
    – Kartagis
    Jan 30, 2016 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.