1

I've just moved a Drupal 7 site from Bluehost to Inmotion (by reinstalling the latest core and adding the 'sites' directory from the old server account, then uploading the database). Since the move I can't log in from the browser.

The DNS has transitioned. At the new location Drupal is installed in a subdirectory -- public_html/sub. I've altered the .htaccess file at the level above (public_html/.htaccess) as per these directions https://support.lunarpages.com/knowledge_bases/article/549 so that the site will open there with the base url in the browser.

That does happen, with the base URL currently showing the under maintenance message, just as the site was left. But when I attempt to go to /user or even /?q=user to log in and resolve any last errors from the move, then bring the site back online, I am not given a login form. It simply continues to show the under maintenance message.

I'm guessing this problem is somehow related to .htaccess and/or settings.php, but I can't seem to find the right combo of changes that will allow me to log in. Any suggestions? (I did clear the cache and sessions tables in the DB when this error first occurred, but no help.)

  • Are you using stock htaccess or customized? – StevenPatz Feb 3 '16 at 22:11
  • At the public_html level (just above the site's subdirectory) I am using the changes from the lunarpages link above to point requests to my Drupal subdirectory. Within the Drupal site subdirectory itself my .htaccess is stock from Drupal. – m.e. Feb 3 '16 at 22:22
0

Update your settings.php to this:

$conf['site_offline'] = 0;

From https://www.drupal.org/node/276457#comment-901392

  • The hosting company's tech support did this, and yes, it does bring the site back online. But /user and other links (including standard menu links) do not work; they simply load the home page. Thus,I still cannot log in. The site is online and broken rather than offline and broken -- but still broken. – m.e. Feb 3 '16 at 22:52
  • Thanks for trying to help. I gave up and moved all the files up to the public_html directory. The site now works. – m.e. Feb 3 '16 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.