3

I just downloaded the EU Cookie Compilance module 8.x-1.0-beta4 and the legal message doesn't show in my page.

First, I configured the module, and then set the Display EU Cookie Compliance popup permission for the anonymous user, but the message doesn't appear.

Why? What do I need to do to make it appear?

1

I have tried it in d6 and d7 and had similar problems in bringing it up for the first time, it showed after enabling the module, setting the permissions to anonymous user, logging out and deleting all cookies from my domain, alternatively using an anonymous browser window. So it might be that you have the cookie already.

3
  • Hi Michael! I delete all the cookies, flush the cache, test in other browsers and nothing the message don't appears.
    – javiregpa
    Feb 7 '16 at 9:51
  • Sorry, then it must be something else and I don't have a 8 site to test, did you activate the cookie pop-up in the module configuration too?
    – Michael
    Feb 7 '16 at 10:07
  • Yes I try all the posibilities, in a new window in a popup and nothing
    – javiregpa
    Feb 7 '16 at 10:45
0

As a workaround, setting the variable $geoip_match to true (line 57 of file eu_cookie_compliance.module) makes the pop up appear:

$geoip_match = true;

I opened an issue in the module's page:

https://www.drupal.org/node/2763441

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.