0

I installed a fresh D8 and was going for the usual setup of sending code and config to repo, and db sync (from a backup dump or sync from remote). Now when I reproduce the site given the code, config, and dump, I notice that the site has no styles.

Comparing the restored setup and another fresh install, I notice that sites/default/files is missing in the restored setup. This directory is ignored by default because it's supposed to house user generated files. However, a fresh install of D8 appears to put files related to theming in that directory.

So my questions are:

  • Why is this directory ignored by .gitignore if theme files reside there?

  • What is the proper way to do this? Should I check-in these files?

  • What else should I or should not I be checking-in?

And we don't have a common remote environment as of the moment so an "rsync from remote" doesn't apply, nor does checking-in archives as we just want code in the repo.

  • 1
    Presumably you have CSS/JS aggregation turned on? If so just clear cache, the problem will be solved. Those files are user generated (or Drupal-generated to be strictly accurate), and they shouldn't be added to git – Clive Feb 10 '16 at 13:46
  • @Clive OMG, aggregation is on by default :facepalm:. Thanks! – Joseph Feb 10 '16 at 13:53
  • I think that the config sync directory should be also present. – user21641 Feb 10 '16 at 14:19
  • @IvanJaros I've already moved it out of sites/default/files so that's aready fine. – Joseph Feb 10 '16 at 14:26
  • cool, then it's just usual git pull & drush cr :D – user21641 Feb 10 '16 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.