2

Watchdog table has become so big that, truncate cascade or delete command in the table is not working at all. The moment the server encounter a DELETE command in watchdog, it gets busy in executing that, all resources are being occupied by DELETE command and server gets very slow. The total functionality can be considered to be null.

Even vacuum full/ananlyze is yielding any result even after waiting for 1 or 2days.

0

You can use truncate command which is faster than Delete. And try using this command directly from Terminal rather than doing "clear log" option available in Recent Log Messages in Drupal 7.

You can find more details on Truncate vs Delete on here.

Hope this helps.

0

I would suggest you to use one of below methods.

  1. Delete entries by range, like you can delete 10000 entries first and check if it takes time then lower the range to 5000 and ... you can also use mysql query to delete the entries

    DELETE FROM table LIMIT range;

  2. If you have access to mysql console than you can directly call mysql commands to delete or truncate table from terminal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.