0

For a current project I have a content type’s textarea set to Full HTML. But where I’ve added a <span> tag, Drupal will go ahead and enclose it within a <p> tag which is definitely not what I want!

It’s also adding an empty <p> tag at the bottom of said container.

How and where can that be turned off? Where is the mechanism or module that is doing that?

1

Sounds like maybe you need to disable the "Convert line breaks into HTML (i.e. <br> and <p>)" filter on your Full HTML text format.

This can be done by navigating to Configuration > Content authoring > Text formats and editors, then editing the Full HTML configuration and un-checking the box for "Convert line breaks into HTML (i.e. <br> and <p>)" under "Enabled filters". Assuming this is Drupal 8 anyway. Drupal 7 has the same setting but the exact location might be different.

  • thanks Joe!, why i was just watching one of your video tuts this a.m...... – TopTomato Feb 15 '16 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.