0

I have a very interesting problem. I have 2 dev machines (both mac, running XAMPP).

In my project I have a submit handler for a custom entity form.

When I try to dpm() (or kpr, or dsm, ...) the contents of $form or $form_state, well, nothing really happens (on one machine!)

On the other machine, the dpm (for the exact same project, in the exact same submit handler, for the exact same variable) works perfectly.

I have copied php.ini settings files, checked the php memory limit, ...

Nothing seems different...

When I try to dpm($form['entities']); then it works on both instances. This seems to give me the impression that it works when you narrow down the array...

But when I inspect the array ($form) it only contains approx. 40 items or so... (okay there are arrays in arrays and so on).

No errors on in the php log, apache log, ...

Any suggestions would be very welcome!

Many thanks in advance!

  • I had a similar case where I couldn't display an array and then it was ruining the whole dsm of the page. but when I removed the buggy dsm it was working fine for the others. I didn't find a solution but it seems some arrays are not working well at all. – GwenM Feb 12 '16 at 15:31
  • Thanks for the comment. But in this case it does not make sense that on one machine it works just fine, and on the other it does not. By now i have also compared with staging environment, and on staging the dpm also works perfectly... – Guardian Feb 12 '16 at 15:40
  • dump the DB which doesn't work and import it in a local environment so you can test it. Try to compare what is different between the nodes/content types. – GwenM Feb 12 '16 at 16:25
0

I had a similar problem. In a submit handler, tried to run dsm($form_state). This caused all submit handlers to not run. If I run $form_state['complete form'] = NULL; before the dsm(), it works. I presume it was too big with the complete form in there.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.