0

I'm using a new host for my website and I requested drush access to my site. They said it's all set and told me to run drush commands as such $ ../drush/drush command

I test it out with $ ../drush/drush status and everything works as it should.

The problem comes when I try to run drush commands remotely via my alias file. Everytime time I drush @remote I get drush: not found

I even set path-aliases to point specifically at %drush and %drush-script.

Is there something I'm missing?

1

If you use, '%path-aliases', either specify the full path to Drush, or ensure that the Drush that you are calling (e.g. drush) is on your PATH.

Example:

$aliases["mysite"] = array (
  'uri' => 'mysite.org',
  'root' => '/path/to/drupalroot',
  'remote-host' => 'myisp.com',
  'remote-user' => 'www-admin',
  'path-aliases' => 
  array (
    '%drush-script' => '/home/myuser/drush/drush',
  ),
);

If setting the PATH in your .bashrc, always do so at the very top of the file. It is common for boilerplate (host-provided) .bashrc files to have a line somewhere in the middle that exits prematurely when not in interactive mode -- and Drush makes remote Drush calls non-interactively in most instances.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.