0

I'm not sure what's happened but I'm suddenly getting Ajax errors for every ajax call, site-wide. An example, from the views UI:

An AJAX HTTP error occurred.
HTTP Result Code: 200
Debugging information follows.
Path: /admin/structure/views/view/about_slider/preview/block/ajax
StatusText: OK
ResponseText: =[{"command":"settings","settings":{"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"bartik","theme_token":"LEKfczQQG6fjcOEWhHnOrh8H-CJ0ihsdmJrl4nOQuAU","css":{"modules\/contextual\/contextual.css":1,"sites\/all\/modules\/views_slideshow\/contrib\/views_slideshow_cycle\/views_slideshow_cycle.css":1},"js":{"modules\/contextual\/contextual.js":1,"sites\/all\/libraries\/jquery.cycle\/jquery.cycle.all.js":1,"sites\/all\/modules\/views_slideshow\/contrib\/views_slideshow_cycle\/js\/views_slideshow_cycle.js":1}},"admin_menu":{"destination":"destination=admin\/structure\/views\/view\/about_slider\/preview\/block\/ajax","hash":"c67043301703a17ae56d13565b86913c","basePath":"\/admin_menu","replacements":{".admin-menu-users a":"1 \/ 1"},"margin_top":1},"viewsSlideshow":{"about_slider-block":{"methods":{"goToSlide":["viewsSlideshowPager","viewsSlideshowSlideCounter","viewsSlideshowCycle"],"nextSlide":["viewsSlideshowPager","viewsSlideshowSlideCounter","viewsSlideshowCycle"],"pause":["viewsSlideshowControls","viewsSlideshowCycle"],"play":["viewsSlideshowControls","viewsSlideshowCycle"],"previousSlide":["viewsSlideshowPager","viewsSlideshowSlideCounter","viewsSlideshowCycle"],"transitionBegin":["viewsSlideshowPager","viewsSlideshowSlideCounter"],"transitionEnd":[]},"paused":0}},"viewsSlideshowCycle":{"#vi...http:\/\/mtairy.toomodernmedia.com\/sites\/default\/files\/styles\/461x307\/public\/IMG_3936.JPG\" width=\"461\" height=\"307\" alt=\"\" \/\u003e\u003c\/div\u003e  \u003c\/div\u003e\u003c\/div\u003e\n\u003c\/div\u003e\n\u003cdiv id=\"views_slideshow_cycle_div_about_slider-block_2\" class=\"views-slideshow-cycle-main-frame-row views_slideshow_cycle_slide views_slideshow_slide views-row-3 views_slideshow_cycle_hidden views-row-odd\"\u003e\n  \u003cdiv class=\"views-slideshow-cycle-main-frame-row-item views-row views-row-0 views-row-first views-row-odd\"\u003e\n    \n  \u003cdiv class=\"views-field views-field-body\"\u003e        \u003cdiv class=\"field-content\"\u003e\u003cp\u003eEvery season we organize age and skill based baseball leagues open to all children in the area.\u003c\/p\u003e\n\u003c\/div\u003e  \u003c\/div\u003e  \n  \u003cdiv class=\"views-field views-field-field-image\"\u003e        \u003cdiv class=\"field-content\"\u003e\u003cimg typeof=\"foaf:Image\" src=\"http:\/\/mtairy.toomodernmedia.com\/sites\/default\/files\/styles\/461x307\/public\/IMG_4087.JPG\" width=\"461\" height=\"307\" alt=\"\" \/\u003e\u003c\/div\u003e  \u003c\/div\u003e\u003c\/div\u003e\n\u003c\/div\u003e\n\u003c\/div\u003e\n\u003c\/div\u003e\n  \u003c\/div\u003e\n\u003c\/div\u003e\u003c\/div\u003e    \u003c\/div\u003e\n  \n  \n  \n  \n  \n  \n\u003c\/div\u003e\u003c\/div\u003e\u003c\/div\u003e","settings":null},{"command":"insert","method":"prepend","selector":null,"data":"","settings":null}]

It appears as if some values are being left null, and I'm thinking that could be a clue to the cause of the problem.

Jquery.js is being loaded. I'm not getting any errors in the console.

Any help with debugging, heuristics, etc greatly appreciated.

4
  • Other Jquery on the site (Jquery sliders) are working fine. This is only affecting ajax. I feel like some resource isn't being loaded, but I don't have much of a clue what or why... Commented Jan 6, 2012 at 16:49
  • Which theme are you using is it a your_own ( custom ) theme or one of the default themes of drupal 7.
    – 15dk51
    Commented Jan 6, 2012 at 16:51
  • @dkiscool I've disabled my custom theme - the problem persists despite the theme (basic, bartik, my custom theme, etc) Commented Jan 6, 2012 at 16:54
  • Related: Cannot edit my views.. I get a JSON string?
    – kenorb
    Commented Aug 25, 2015 at 15:46

1 Answer 1

-2

Visit jquery update settings (intall, if it's missing) and set a different jquery version on "Alternate jQuery version for administrative pages" section.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.