0

The Drop-Down menu on a site I manage has stopped working. The link is here: http://www.lslib.com/ I suspect it might be a jQuery issue but I have installed the jQuery Update module but it still does not seem to work. Any hints on what I may be missing or what needs to be fixed?

Thank you!

I see something like this in my html:

<script type="text/javascript" src="//code.jquery.com/jquery-1.10.2.min.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.jQuery || document.write("<script src='/sites/all/modules/jquery_update/replace/jquery/1.10/jquery.min.js'>\x3C/script>")
//--><!]]>
</script>
<script type="text/javascript" src="http://www.lslib.com/misc/jquery.once.js?v=1.2"></script>

and I imagine a browser might take jquery 1.2 instead on 1.10. I could npt find which template <script type="text/javascript" src="http://www.lslib.com/misc/jquery.once.js?v=1.2"></script> is coming from. How can I remove this?

  • please confimr whether you have enabled the expand option in menu setting. -Anas – Anaz Feb 16 '16 at 6:59
1

Looks like you are getting a javascript error in your superfish.js file.

Uncaught TypeError: Cannot read property 'msie' of undefined

The $.browser method has been removed as of jQuery 1.9.

https://www.drupal.org/node/2111995

As stated in the Upgrade Guide you can try using the jQuery Migrate plugin to restore this functionality and let jQuery Tools work or you can use an earlier version of jQuery for your site (1.8 for example)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.