1

I using Windows 8.1, XAMPP 3.2.2 and Drupal 8.0.3.

When I install Drupal, it only gives an option for Database as SQLite and it stores the file in drupal->sites->default->files. Then inside the folder 'files' name of the SQLite DB is drupal.ht.sqlite.

I want to use MySQL as DB instead of sqlite, Please help me to get out of this problem. And I have add some content it is working fine.

  • 1
    Does phpMyAdmin work under your MAMP to connect to the local database server? Are there any warnings on the Verify Requirements screen before you are asked for database credentials? If you add a simple file with just <?php phpinfo() in it, do you see MySQL entries? – mpdonadio Feb 17 '16 at 13:02
  • Thanks for your comment. Dear MPD I have mention in my query that I am using xampp. I am not using mamp. And phpmyadmin is working fine. – Manpreet Singh Feb 17 '16 at 13:51
  • Please don't add the Drupal version in the title; we have the 8 tag for that purpose. – kiamlaluno Feb 17 '16 at 15:23
0

I think you need to have the pdo-sql PHP module activated if you want to use MySQL, otherwise the MySQL option will not appear. For more details, see no mysql option at install.

  • You are the man dinopmi. Thanks a lot and lots of hugs. Problem solved. And name of the extension in 'php.ini' file is 'extension=php_pdo_mysql.dll'. – Manpreet Singh Feb 17 '16 at 14:28
  • You are welcome! If your problem was solved, don't forget to mark one of the two answers you received as "accepted" (Clive's answer was essentially the same as mine, but more detailed). Like that, your question will not be listed in the "Unanswered" section anymore. – dinopmi Feb 17 '16 at 14:36
2

You won't be able to convert an existing site as far as I know; you'll need to build a new site and migrate the content over to it. It might be easier to just start a new site from scratch and export/import the data manually, depending on how far you've got.

Before you do that, you need to enable MySQL in PHP. If you only see SQLite as a DB option, it means you haven't installed the PDO MySQL extension. Consult your web server's documentation for instructions on how to do that.

Once you have, MySQL will appear as an option for installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.