2

Im using Drupal 7.41 and Omega3 sub theme and Ckeditor. I have added a sentence in the style of heading (h1) at the top of my Home Page content, it shows in Ckeditor using the source button (showing markups) with H1 tags around the heading, and shows in the style of H1 normally in Ckeditor. When I save and close off the edit, it just appears as normal text, and as P tags when I view via Firefox (View Source) , the H1 markup is not showing, when I go back into Ckeditor, I can see its in the style of H1 and when I click Source button, i can see it has the H1 tags around it. When I View Source on Firefox, it shows as P tags. I have flushed Cache, and checked but it still shows as P tags.

Basically, its showing correctly in Ckeditor (with/without clicking Source button), the markup is not getting wiped, but its just not showing when I view the webs page when I come out of Ckeditor (either logged in or not). Can anyone help?

1
  • Do you use filter html or a custom one? Check the settings of the html you're using
    – GwenM
    Feb 18 '16 at 14:31
3

go to:

/admin/config/content/ckeditor/edit/Advanced (for Filter HTML)

/admin/config/content/ckeditor/edit/Full (for Full HTML)

Then under Advanced Content Filter, select disabled.

enter image description here

If the above does not do it, depending on which one you are using (filter or custom) You need to go to

/admin/config/content/formats/filtered_html

add the <h1> to the limit allowed html list

enter image description here

1
  • 1
    thank you so much. I had disabled everything in CKeditor, but not allowed the H1 tag in Content / Formats. all working fine now after flushing cache. Feb 18 '16 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.