2

In settings.local.php, I have set my local dev environment to use the Devel module's mail logging function:

 $config['system.mail']['interface']['default'] = 'devel_mail_log'; 
 $config['devel']['settings']['debug_mail_directory'] = "???";

The DevelMailLog documentation says that:

Filename pattern controlled by 'debug_mail_file_format' config setting.

What do I put for the filename pattern? I have tried several patterns:

  • public://devel_mail
  • private://emails
  • sites/default/files/devel

But none of these work. I checked watchdog, but apparently devel mail doesn't leave any logs.

NOTE 1: There is a note in the docs that config settings are broken, but the linked issue is already fixed.

NOTE 2: By default, when I enable devel and export the config, the value for debug_mail_directory is temporary://devel-mails, but I don't want to store them in the temporary directory; I want to store them in the Drupal files directory if possible.

1

You should use

$config['devel.settings']['debug_mail_directory'] = 'private://mydirectory';
$config['devel.settings']['debug_mail_file_format'] = 'mypattern-%to-%subject-%datetime.mail.txt';
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.