4

I'm running drupal sites on my localhost with virtual host. everything was running perfect but then it suddenly stopped working, I tried to restart apache to fix the error but still not working. It takes about 30 seconds to load the home page, and about the same for other pages. I'm running mac os x with Apache MySQL "no MAMP". thats really confusing me more is that it runs only on firefox, on safari it takes forever and never loads.

7
  • Did you check the error logs? Disable non core modules and theme enable the moules one by one.
    – 15dk51
    Jan 9, 2012 at 15:41
  • apache log shows no erros.
    – saadlulu
    Jan 9, 2012 at 23:14
  • plus that its happening on all of my drupal sites on local machine, other non drupal sites work normally.
    – saadlulu
    Jan 9, 2012 at 23:16
  • Which macos version are you using? In lion you can't use the .local domains anymore because lion will load very slow. more info here: itand.me/mac-os-x-lion-local-domains-and-etchosts-oh-m
    – Gnuget
    Jan 10, 2012 at 0:37
  • I mean drupal error log at your_drupal_site/admin/reports/dblog It will give you an idea.
    – 15dk51
    Jan 10, 2012 at 1:06

3 Answers 3

2

Install devel module in your drupal site. After enabling devel module, you need to enable query log and page timer in devel configuration page. by doing this you will see how much time each function is taking to load and will able to analyze you site.

2
  • devel module didnt catch any query with more than 5ms, but sometimes when I keep refreshing, it shows some queries of over 45ms.
    – saadlulu
    Jan 9, 2012 at 23:15
  • Yes.. Mostly process is that you need to note down those query and search on drupal.org. Because its little difficult to imagine what problem you would be having from here. I think drupal.org would have some solution on that query. Just copy those query and paste into drupal.org search bar. Jan 10, 2012 at 2:22
1

First thing I would check is the apache error log, for any ressource that is 404. It very well could be a logo or an image that is 404 (not found), your page request will try loading the ressource for a certain time depending on your time-out settings, before giving up and closing the request.

1
  • this is not the case since its a fresh installation of drupal.
    – saadlulu
    Jan 9, 2012 at 22:24
0

I went to /etc/apache/users/saad.conf and added the virtual host in this form "www.x.dev" to the top of my virtual hosts list. this temporarily fixed the problem. hope this helps

Not the answer you're looking for? Browse other questions tagged or ask your own question.