I'm using Drupal commerce module. I don't see the Multilingual tab in the product type: product at admin/commerce/products/types/product/edit.

How do I make the product translatable? If that is not posible (hard to believe...) how can I just translate the product title?

4 Answers 4


Entity translation allows to to translate products. To be able to translate the title, you will need to replace it with a field and use that instead. There is the Title project to help with that, but I haven't yet tried if it is compatible with Commerce products.

  • the problem is that entity translation is still in alpha. Is it ready for production site? Moreover, searching ET-translated content is still problematic. There are some modules about search but they are all still in dev or alpha version.
    – john
    Jul 25, 2012 at 1:01
  • 1
    Entity Translation is alpha, it's still changing, the new version comes with a completely rebuilt UI that uses the default entity form instead of a seperate one. However, there is no alternative, that's the simple truth :) Broken/problematic search isn't a problem of the entity_translation module, it's an issue with the translatable fields concept, which is provided by Drupal core. There is unfortunately no generic search solution for translatable fields available that I'm aware of.
    – Berdir
    Jul 25, 2012 at 20:11
  • 1
    We built an one-off solution for one site by exposing each field for each language to Search API, but that was only possible because the site is a) limited to 2 languages (the fields settings page is already huge for one language with many fields) and b) the search is only accessed through the API, where we can easily switch to the language specific fields with some wrapper functions. The opposite is drupal.org/project/search_api_et, which just exposes the content of all languages so that it can be indexed but it's not possible to limit the search to a specific language.
    – Berdir
    Jul 25, 2012 at 20:14

You need to enable the translation for the "product" content type.

Enabling translation support for a content type

  1. Navigate to the Content types administration page (Administration > Content > Types in Drupal 6, or Administration > Structure > Content types in Drupal 7).

  2. Select a content type you want translated, (in your case 'products') and select "edit", then "Workflow settings" for Drupal 6 or "Publishing options" for Drupal 7.

  3. At the "Multilingual support" section, select "Enabled, with translation". Be sure to save each content type after enabling multilingual support.

For more information on this procedure and more I18N tips, see this page.

Hope that helps, happy coding friend.

  • What you say works for any content type but it doesn't work like that for product types with the drupal commerce module.
    – chefnelone
    Jan 9, 2012 at 19:48
  • 1
    Yes. You are totally right my friend, sorry about that. I would of actually deserved a -1 on that, but I setup commerce to check this out and indeed, the concept has changed. Google turned me a few links to the commerce user guide site, and unfortunately I have not found a decent solution. This is sad, because I also will be needing commerce very soon, and it seems very sketchy. Here is the link to the I18N related pages on the commerce user-guide site: drupalcommerce.org/search/node/I18N. Good-luck, will be checking back for updates, and looking on my end for an answer to this. Jan 9, 2012 at 20:35

Unfortunately, Entity Translation coupled with Title don't take you the whole way if you're using Commerce Kickstart, there's a bug that makes it a real bother to translate product fields. I've constructed a small guide for this purpose which also includes some code to work around that bug: http://storleden.se/blogg/how-translate-products-drupal-commerce


You can use the Internationalization for commerce product module.

Here is a quote about it (from the project page):

... allows you to translate commerce products. You need it if you have multilingual site with e-commerce via commerce module.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.