3

The error appears on a single language page with just one other language than English enabled (here: German) and set to default. All other admin pages show the the right language. Admin theme is "seven". I know, this is probably to broad or localized, but I can't wrap my head around this one...

Update: I have installed "Administration Toolbar" and this fixes at least language error in the toolbar. If i deliberately enable the "better toolbar" - option (that means 2 toolbars, one is drupal core and the other from "Administration Toolbar" at the same time), one shows up in German as it should and the drupal core one still in English.

But all the other text strings are still in English. Although they are present and properly translated on the "translate interface"-page (admin/config/regional/translate/translate).

I have installed the latest .po (7.43) file for German, cleared cache several times but to no avail.

Any hint where to look?

UPDATE II: Bug is related to Features module (https://www.drupal.org/node/2636140) That one was hard to track down.

UPDATE III: The bug was fixed in the latest Feature module update (7.x-2.8)

3
+50

I did a similar verification in one of our sites, which has 3 languages (EN, NL and FR). I disabled the "module_filter" module, so that I could see what the result would be if I look at what's shown on admin/modules. I also use "admin menu", but for my verifications I've not experimented with anything related to that menu (I just wanted to check what the CONTENT of admin/modules actually is, depending on the language I used. And I experimented with EN and NL (=Dutch), assuming that FR would give similar results like NL. And I've been using the (same) Seven theme for admin

To actually do my experiments, I've enabled the "language switcher block" so that it is shown within my theme used for Administration. I have this block shown in the "Content" region above the block "Main Content Page" (so that I can switch between EN and NL for my experiment). BUT: nowhere in the question here it says anything about using that "language switcher block". So that's already something for you to check: you are aware I assume about how to use that block for switching languages, right?

Anyway, when I then use that language switcher block to switch from EN to NL, PARTs of what is shown on that page is in NL (Dutch), though other parts remain in EN. E.g.:

  • the descriptions for my modules (from the .info files) are shown in Dutch
  • but the strings like "Requires" and "Required by" are NOT translated in Dutch. Though the values like "(enabled)" or "(disabled)" or also translated to NL, like to "(ingeschakeld)" or "(uitgeschakeld)".
  • the (hardcoded) tekst near the top, like "Download additional ..." is NOT translated.
  • typical messages (in green, yellow or red) near the top are translated to NL also.
  • Module names, like "Color" are not translated (to something like "Kleur").
  • links like "configure" are also translated to "instellen".
  • module groups like "Core" are translated to "Kern".

With all this, I have the impression that by using the "language switcher block" and setting it to the NL-language, this admin/modules page gives me an "as good as it gets" translated version of that entire page. But if you don't use that "language switcher block" (to switch to NL), then everything remains in EN (of course). And for things that are not translated, I guess that's because it's either not using the typical t() function, or the required translated string is still missing (for NL in my case).

Not sure to what extend it will actually answer your question, but at least it should help to understand what is happening, and how the "language switcher block" seems to be part of the puzzle.

But, don't worry ... D8 has a lot of improvements for multi-language stuff (not sure yet about this specific "issue" however ...).

| improve this answer | |
  • Pierre, your insight is appreciated as always. This time it was not specifically related to multilingual stuff, it's rather a Features caching process problem. (drupal.org/node/2603578) Thanks anyway – Volker Mar 4 '16 at 8:39
  • Wooooow, your "update II" (and own answer) is of course a completely different animal (you were lucky you discovered that ...). But still, I'd be interested if in your case you would get similar results as mine if you'd make "EN" (temporary) the default language (knowing that I have "no" features in the site I checked). Have some dev site hanging around (with 2 or more languages enabled) to quickly check that? – Pierre.Vriens Mar 4 '16 at 8:55
  • Pierre, i have added another answer so i could post an image. My results are a bit different... – Volker Mar 4 '16 at 9:52
  • Merci for the bounty! And BTW, I did various additional experiments in the meanwhile, based on some of the things you wrote in your own answer. But still I couldn't get it to work entirely as it should. I will keep trying / searching. If I find it, I'll further update my answer about it here. – Pierre.Vriens Mar 10 '16 at 21:00
1

To get rid of the dual toolbars, just disable the toolbar module from modules and you'll just have adminstration menu toolbars left enabled.

As for the language issue, please check the link url, as I assume you're using admin overlay, then the overlay part has it's own language tag as such:

http://dev.mysite.com/en/blog/lalala#!=&overlay=en/admin/modules

Notice the two language "variables"?

| improve this answer | |
  • Thanks. I'm not using the overlay. The second toolbar was added deliberately and i know how to get rid of it ;). It was just for testing purposes. It is a single language page, only German is active and set to default (you can't disable English). I don't have the path prefixes for language as i don't use translations. And only the admin/modules page shows in english instead of german. – Volker Mar 3 '16 at 17:22
  • Overlay was a good hint anyways. When enabled, the language was correct, but due to incompatabilty with latest jquery, this was not the way to fix it. I have updated my question, bug is related to Feature module. – Volker Mar 4 '16 at 8:37
1

The bug described in my question is related to the Features module. I found this by chance, when updating modules on another drupal-site, when afterwards the same error appeared. So I disabled every updated module one after another. After disabling Features everything went to normal. A quick scan of the modules issue queue revealed some other people with the same symptoms. Reference:

Enable feature module cause modules listing page into English.

_features_set_export_language is clearing drupal static cache too aggressively breaking search and possible many other modules

| improve this answer | |
1

@Pierre.Vriens I have some slightly different results. Language detection had to be set to "Determine the language from the URL (Path prefix or domain)." though. I have enabled dutch to test. Enabled is just the basic i18n module.

enter image description here

| improve this answer | |
  • Hm, interesting! I'm assuming apart from "Dutch" you also had (eg) "English" enabled. If that's the case, what is your "default" language? – Pierre.Vriens Mar 4 '16 at 10:13
  • I had "German" as default language, but the result stays the same wheter i change default to NL or EN. – Volker Mar 4 '16 at 10:18
0

Use that module (admin_menu) also after disabling toolbar module it will display menu links when you hover the parent items which eases navigation to internal pages by just one click.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.