1

I have a rest export that exports various content types. However I am running into the problem of the export giving me empty no result attributes. Here is an example.

{ "title": "Acme Porter Image", "body": "", "field_image": "http://192.241.172.112/sites/default/files/2016-02/beer-batter-is-better_1_2.jpg", "field_videosour": "" }, { "title": "Acme Porter Description", "body": "This thing has more hops than Michael Jordan. It is dark and has hints of chocolate", "field_image": "", "field_videosour": "" }, { "title": "Acme Porter Video Review", "body": "", "field_image": "", "field_videosour": "https://www.youtube.com/watch?v=JCpLerLKD2k" }

Does anyone know how to get rid of the no result elements from the response?

Thanks, Emmanuel

  • Does the Hide If Empty option in views No Results Behavior configuration do anything? – mradcliffe Mar 1 '16 at 14:51
  • Nope I have that on. If I put in a no result message in that field, that message gets put into the empty string. However I can't find how to just avoid that element entirely. – emmanvazz Mar 1 '16 at 16:05
  • Probably a bug/feature request that should be reported. – mradcliffe Mar 1 '16 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.