1

It seems like this should be super simple, but I can't seem to figure it out...

I have layouts with headings and subheadings, (shown below) where the highlighted/top heading is the page/node's title.

enter image description here

So the issue I'm having, is that the system then makes the slug "stay-connected-with-campus" but I want it to be "parents" and "parents" is just redirecting to "stay-connected-with-campus"

Where or how can I control that?

My URL path Settings:

enter image description here

And there are no redirects set:

enter image description here

Thanks!

  • did you flush/clear the cache? – No Sssweat Mar 3 '16 at 2:25
1

If you want control over the generated URL, then you need to enable the Path or Pathauto modules. Once these are enabled, Edit the piece of content for which you want to set a specific URL path, and go to "URL Path Settings" to do this.

  • Thanks, I thought that should be it but I have it configured but it's just redirecting to "stay-connected-with-campus" - I will update my post with my settings. – ByteMyPixel Mar 2 '16 at 17:58
  • You say in the question that "parents" is just redirecting to "stay-connected-with-campus"(is this a root-level /stay-connected-with-campus?) - Are you saying that "/parents" is redirecting to "stay-connected-with-campus" or that "/current-students/student-development/information-for-parents/parents" is redirecting to "stay-connected-with-campus" ? Also, what is the Title of your piece of content? – Monkeybrain Mar 3 '16 at 10:41
  • Sorry, this site was inherited... it turns out the site was configured to set URL aliases automatically so as page titles were being changed the url changed, and we had a mess with multiple aliases assigned to a given URL... but got it all cleaned up, by removing the automatic alias setting and cleaning up all of the redirects. Thanks! – ByteMyPixel Mar 3 '16 at 18:42
  • Glad you got it sorted. Just FYI, if you resolve your own problem it is useful to add this information to your post, so that other users coming across it in future can benefit from the details of your solution. See meta.stackexchange.com/questions/96395/… . Best regards, Monkeybrain – Monkeybrain Mar 3 '16 at 19:52
0

It turns out the site was configured to set URL aliases automatically by default, so as page titles were being changed, the url changed. This created a mess with multiple aliases being assigned to a given URL. Removing the automatic alias setting and cleaning up all of the redirects fixed these issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.