0

I have installed the Heartbeat module (6.x-4.11) with Heartbeat activity and Heartbeat rules enabled. If a user adds a comment to the site the activity is being logged in the database and showing on the public heartbeat page. However, looking at the user's personal heartbeat it shows as "no activity yet."

The uid and uid_target values in the database table are both "0" which I am guessing is not right (surely these should be the user's id).

Is there a configuration setting that controls whether the activity appears against the user?

I'm attempting to use this module as a way of allowing users to see how active other users are on the site; so it is important that the activity appears against the personal heartbeat.

1
  • I do not have the same issue with adding new content. This works fine. Jan 12, 2012 at 12:18

1 Answer 1

1

Finally sussed it. I needed to go into the Triggered Rules page and change the "do" behaviour for the "Heartbeat: When a user adds a comment" rule.

Setting "User Id" to "[comment_author:uid]" links the activity log to the author, and "Node context Id" to "[node:nid]" links to the node being commented on. After changing these the activity showed up in both personal and public Heartbeat activity streams.

Hope this helps somebody else who may be struggling with this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.