0

Since I created my site (long time ago!) I have added content and changed many settings. My URL has always been www.domain.com/'drupalfolder'/(content)

I want to remove the drupal folder from the URL and just have my domain name (www.domain.com/content)

I have moved (manually) all the contents of the drupal folder on the 'public' folder but when I try and log in I get not found page or access denied. I have tried to clear the caches before and after but still nothing. I had to change the main menu urls manually... I want all the URLs to change automatically!

Am I doing it properly? is there a process I can follow to save me time?

UPDATE: I do not have access to the .htaccess file as only my host has access to it ---- I am using cPanel

  • What is the base URL you have set in settings.php? What is the root you have set in .htaccess? – choster Mar 3 '16 at 17:57
  • I'd wager that your site uses Drupal's default .htaccess. However, did you update your settings.php to reflect your new base path? # $base_url = 'http://www.example.com'; If you moved your drupal root dir to your shared host's root directory, you should be able to comment out that line. You do so by adding a '#' at the beginning of that line. – Screenack Mar 4 '16 at 1:48
0

All URL will be changed automatically, if u have not provide static URL in it. For further checking what is causing the issue, check your apache log (if your server is Apache2)

cd /var/log/apache2
tail -100 error.log

See the latest error which is showing, or paste it here.

| improve this answer | |
  • I am getting a [authz_core:error] [pid 32319] AH01630: client denied by server configuration in the cPanel server log – TheAdmin Mar 3 '16 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.