0

I've been running a Drupal 8 site since 8.0.0, using the Address module. As this required some CommerceGuys dependencies in the /vendor folder, I've been using the following commands to load dependencies (and update to newer versions of other components):

php sites/all/modules/composer_manager/scripts/init.php
composer drupal-update

However when I run this for 8.0.5, I'm getting the following error (not all output included):

Drupal\Core\Composer\Composer::vendorTestCodeCleanup

  • Removing guzzlehttp/promises (1.0.2)
  • Installing guzzlehttp/promises (1.0.3)

Drupal\Core\Composer\Composer::vendorTestCodeCleanup

  • Removing guzzlehttp/guzzle (6.1.0)
  • Installing guzzlehttp/guzzle (6.1.1)

Drupal\Core\Composer\Composer::vendorTestCodeCleanup

  • Removing symfony/browser-kit (v2.7.6)
  • Installing symfony/browser-kit (v3.0.3)

Drupal\Core\Composer\Composer::vendorTestCodeCleanup

  • Removing fabpot/goutte (v3.1.1)
  • Installing fabpot/goutte (v3.1.2)

Drupal\Core\Composer\Composer::vendorTestCodeCleanup

  • Removing behat/mink (v1.7.0)
  • Installing behat/mink (v1.7.1)

Drupal\Core\Composer\Composer::vendorTestCodeCleanup
Script Drupal\Core\Composer\Composer::vendorTestCodeCleanup handling the post-package-update event terminated with an exception

[RuntimeException]
The directory 'tests' in package 'behat/mink' does not exist.

The CommerceGuys modules components are not getting loaded. I'm not sure if this is because of the above exception.

This has worked for every previous Drupal 8 update, so I'm not sure what's different this time.

3

There is a patch available here - https://www.drupal.org/node/2664274#comment-10954323, which is RTBC.

I can confirm it's working :)

  • Yes, I found the patch and it resolved the problem. Then Drupal 8.0.6 came out a couple of days later. :-) – James Shields May 3 '16 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.