I created a Forena report using a data block that has one parameter in it, i.e. ":year".

When creating the report, the parameter is detected and added to the report definition. When previewing the report a textbox is shown to let me enter a value and test the report. However after saving the report no text box displays to allow data entry for this parameter. I have checked the settings for the parameter and the "Input Control Type" is set to Textbox. I have tried both Yes and No settings for the "require" setting.

parameter settings

parameter result

2 Answers 2


Have a look at the tutorial about Forena report parameters. In the end, they are technically stored (saved) as part of the so called .frx files (which contains all of your report specification details). Here is a (partial) example of such frx-file:

<head id="frxsrc">
  <title>My Report Title</title>
    <frx:parm id="state" label="State" require="1"
      desc="Select a state from the list."
      data_source="sampledb/states" data_field="" type="select">

So when you're creating ("writing") a report specification (eg using the WYSIWYG report writer), part of what you actually do is saving a special kind of "content" in XHTML format. And that's where the typical "text formats" get involved (just like any kind of content you'd save in Drupal).

However, because of the way Forena does certain things to process these XHTML files (report specifications that Forena massages in reports/charts that match your specifications), it's important that as part of the Forena installation/configuration, you "Prepare a text format to be used by Forena", as explained in the Forena Setup Guide. Here is the crucial part of it:

Regardless as to which Input Format you choose to use with forena, make sure these entries are turned of for the chosen text format :

  • Limit allowed HTML tags.
  • Display any HTML as plain text.
  • Convert line breaks into HTML.
  • Correct faulty and chopped off HTML.

Anybody who starts using Forena without completing (or knowing about) this crucial configuration step, will typically run in this first-time configuration error ... Same happened to me when I first tried to use Forena some years ago.


The issue turned out to be the Forena setting for Input format.

At admin/settings/forena I set the input format to "Unfiltered" and gave a role permission to use that format.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.