0

I have a contextual filter on the field content: tags set to "Match any value," but in practice, it appears that only nodes that match the first tag are displayed. For instance a node with the tags "blue, green" would show only other nodes tagged "blue."

0

It usually work better when you add a relationship to the view, where you relate the content to the taxonomy term. Then you unlock a whole new collection of fields and filters.

Choose to filter by taxonomy - name instead of content - tags.

| improve this answer | |
  • Thanks Neograph. I added the relationship like you suggested. It still appears to be using only the first tag of the node providing the filter. However the filter returns nodes that have the tag in any position (1st, 2nd, ... nth). – AndrewE Mar 10 '16 at 16:56
  • Just adding the relationship is not enough. After adding the relationship you have to remove the current filter and create a new filter for taxonomy:name instead of node:tags. Your comment implies you only added the relationship. – Neograph734 Mar 11 '16 at 1:03
  • Sorry, you're right about my comment. I followed your advice completely and was left with the results stated. – AndrewE Mar 17 '16 at 12:42
  • Do you have aggregation or distinct query results enabled? – Neograph734 Mar 17 '16 at 13:16
  • 1
    I was mistaken. "Taxonomy: name" didn't provide any results, but "Taxonomy term: Term ID" did provide results that matched the first tag, whether or not the default was set to match "any" or "all" taxonomy terms. The "Distinct" box is not checked under "Query settings." I couldn't find an aggregation setting. Thanks for your help. – AndrewE Mar 17 '16 at 16:52
0

The setting I was missing was under Advanced=>Contextual Filters=>Taxonomy term: Term ID=>More and check "Allow Multiple Values"

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.