0

I see an error when i want disable apachesolr module. what should i do? enter image description here

2

Updated:

Point from @kiamlaluno is correct, the apachesolr_stats has apachesolr listed as a dependency. Therefore, in order to disable the apachesolr, you should first disable the apachesolr_stats (and possibly other dependent modules).

I suspect that this issue comes from cached blocks, when I look at the trace you posted. Try to clear the cache and/or disable the apachesolr_stats block before trying to disable the apachesolr module.

Original:

You should try to disable the apachesolr_stats module first. If you are using drush, this would be the command:

drush dis -y apachesolr_stats

If you don't have drush, you can also use MySQL/PHPMyAdmin commands, here are some links with examples:

Disabling modules:
https://www.drupal.org/node/157632

Clearing cache:
How do I clear cache using an SQL query? [if that answer works for you, you can upvote ;) ] https://www.drupal.org/documentation/clearing-rebuilding-cache

Good luck!

  • Should not Drupal avoid the user disables a module that has depending modules enabled? As far as I remember, I cannot even select a module from which other modules depend on, to disable it. – kiamlaluno Mar 14 '16 at 12:56
  • my drupal only shows this error, not anything else. I don't know how i can install drush on windows. is there another way ? – Hamed Mar 14 '16 at 13:01
  • Hey Hamed, I updated my answer, have a look. – Stefanos Petrakis Mar 14 '16 at 13:45
  • thank you stefanos. sorry for long delay. now my problem is finding a complete solution to install drush on windows 10. I searched very very much. – Hamed Mar 31 '16 at 18:52
  • Hey Hamed, no problem, it's good to see you coming back to this. Let's try to solve this. About drush, I open a new question "Drush on Windows 10", if there is not one there already. For this question, you can also disable a module and clear the cache tables from your MySQL (phpmyadmin), I updated my answer. – Stefanos Petrakis Mar 31 '16 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.