1

hello I encounter difficulties to display a date in the correct format in a view.

I souhaire display my dates like this 2009-07-19T03:00:00+01:00

I created a new format here / admin / config / regional / date-time / formats here that Y-m-d\TH:i:sP

Then I created a new type of date and selected my new format. When I go to my view, I select my new date format but the field shows a different format 2016-03-17+01:00 +01:00

So I have a time zone more and I miss the hour, minutes and seconds. Do you have a solution ?

  • Is this Drupal 7 or 8? – No Sssweat Mar 17 '16 at 19:06
  • is this Drupal 7 – user59029 Mar 17 '16 at 22:07
  • In views, for date formatter select custom and put Y-m-d\TH:i:sP and see what happens. – No Sssweat Mar 18 '16 at 9:29
  • hello, yes I have set the parameter fields on my custom date – user59029 Mar 18 '16 at 11:58
  • like this? – No Sssweat Mar 18 '16 at 11:59
1

Try doing it like this, which works fine for me:

For date format select Custom and then enter Y-m-d\TH:i:sP

enter image description here

enter image description here

  • I have no personalized format in my view. Watching capture date1.jpg – user59029 Mar 18 '16 at 14:08
  • Use "custom" instead of "google shopping" – No Sssweat Mar 18 '16 at 14:11
  • I have only the short format, medium, long, google shopping and weather. – user59029 Mar 18 '16 at 14:40
  • that's very weird, custom should show up under short format as seen here – No Sssweat Mar 18 '16 at 14:48
  • yes it is weird, but I want to display the discount date. Maybe is there a problem with the discount Module – user59029 Mar 18 '16 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy