0

I'm a Drupal newbie and haven't been able to find this problem posted elsewhere online, so I'm hopeful someone here can help.

I have just set up php/mysql on a shared hosting environment and copied drupal 8.0.5 over to begin the installation (I changed some file permissions and copied settings.php and .htaccess over to the correct locations as per the instructions).

The server seems to be running MariaDB 10.0.23-MariaDB~trusty (debian maybe?) and ostensibly php 5.6. However, when I run php --version on the server I get PHP 5.5.32-nfsn1 (cli) (built: Mar 11 2016 21:11:51). However, Drupal hasn't complained so it seems to agree that they're running 5.6.

Where I'm getting stuck is during the installation phase, where it breaks about half way through with the following error message:

An AJAX HTTP error occurred.
HTTP Result Code: 200
Debugging information follows.
Path: /core/install.php?rewrite=ok&langcode=en&profile=standard&id=1&op=do_nojs&op=do
StatusText: OK
ResponseText: Drupal\Core\Database\DatabaseExceptionWrapper: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'drupal.watchdog' doesn't exist: INSERT INTO {watchdog} (uid, type, message, variables, severity, link, location, referer, hostname, timestamp) VALUES (:db_insert_placeholder_0, :db_insert_placeholder_1, :db_insert_placeholder_2, :db_insert_placeholder_3, :db_insert_placeholder_4, :db_insert_placeholder_5, :db_insert_placeholder_6, :db_insert_placeholder_7, :db_insert_placeholder_8, :db_insert_placeholder_9); Array
(
[:db_insert_placeholder_0] => 0
[:db_insert_placeholder_1] => DrupalKernel
[:db_insert_placeholder_2] => Container cannot be saved to cache.
[:db_insert_placeholder_3] => a:0:{}
[:db_insert_placeholder_4] => 3
[:db_insert_placeholder_5] => 
[:db_insert_placeholder_6] => http://www.mysite.info/core/install.php/?_format=json&id=1&langcode=en&op=do&op=do_nojs&profile=standard&rewrite=ok&rewrite=ok
[:db_insert_placeholder_7] => http://www.mysite.info/core/install.php?rewrite=ok&langcode=en&profile=standard&id=1&op=start
[:db_insert_placeholder_8] => 43.247.118.190
[:db_insert_placeholder_9] => 1459041023
)
in Drupal\dblog\Logger\DbLog->log() (line 84 of /home/public/core/modules/dblog/src/Logger/DbLog.php).

clicking the link to the error page takes me to this:

Catchable fatal error: Argument 1 passed to Drupal\Core\Routing\CurrentRouteMatch::getRouteMatch() must be an instance of Symfony\Component\HttpFoundation\Request, null given, called in /home/public/core/lib/Drupal/Core/Routing/CurrentRouteMatch.php on line 92 and defined in /home/public/core/lib/Drupal/Core/Routing/CurrentRouteMatch.php on line 104

I can't make a lot of sense of this message. A quick google search lead me to a bunch of pages for similar errors, but I couldn't find this same issue.

As this is the only database in the mysql instance I have simply given drupal the admin user/password, so I don't see how this could be a permissions issue.

I have not made any modifications to any files, other than copying default.settings.php -> settings.php.

What am I doing wrong here?

As per another user's request, I tried upgrading to drupal 8.0.6 and am now getting a 500 internal server error, with the following in the logs:

[Fri Apr 08 14:11:53.710451 2016] [core:error] [pid 54807:tid 34478458880] [client 172.17.240.6:45115] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

I've posted another question to resolve this issue: https://drupal.stackexchange.com/questions/197400/500-server-error

  • Are you installing a fresh Drupal 8 installation or using a profile? – Mohammad AlQanneh Apr 3 '16 at 8:17
  • @MohammadAlQanneh it's a completely fresh install. – quant Apr 3 '16 at 10:41
  • Sounds like there is an error or notification occurring early on during install, before the Watchdog table has been created. Pity you can't attach a debugger to DbLog.php and work backwards. – J. Reynolds Apr 5 '16 at 12:11
  • I think the install is failing to connect to the mysql server.Are you using a local mysql server? Check if the my.ini has a skip-networking entry, that would prevent you from connecting. I also had trouble using localhost as the host entry, make sure to test with both localhost and 127.0.0.1. – Balazs Dianiska Apr 6 '16 at 13:52
  • @BalazsDianiska I am not using a local mysql server. – quant Apr 8 '16 at 14:21
1

This is weird, since exactly in 8.0.5 is fixed that kind of error:

#2646410 by claudiu.cristea, dawehner: Container cannot be saved to cache

Can you try Drupal 8.0.6 maybe? Your MariaDB as well as PHP seem to be compatible with D8 requirements (your MariaDB is based on 5.5 plus Mysql 5.6 stuff).

  • I just copied drupal 8.0.6 to the public directory on the web server, but now I get a 500 "Internal Server Error". Looking at the server logs: [Fri Apr 08 14:11:53.710451 2016] [core:error] [pid 54807:tid 34478458880] [client 172.17.240.6:45115] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace. – quant Apr 8 '16 at 14:20
  • It seems to me like drupal devs are a bit liberal with their definition of "stable". As a drupal beginner, should I be using Drupal 7 instead? – quant Apr 8 '16 at 14:25
  • @quant: Drupal 7 is way stable than 8 (and a bit faster). Also, since D8 is new, there are not many modules ported for it, unlike D7. If you can, I advise to wait up with using D8. Keep an eye on it for a few months and then try it again. As for the error, check stackoverflow.com/questions/19071324/… – milovan Apr 10 '16 at 17:57
  • I upgraded to 8.0.6 and got the same error. I'm giving up and going with Drupal 7. – quant Apr 13 '16 at 1:50
  • Drupal 7 gives me 500 errors. Posted this same question on the drupal site instead: drupal.org/node/2705087 – quant Apr 13 '16 at 2:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.