2

Drupal Commons site has no style after installing it: It looks like campus-24.com.

Note the JavaScript and CSS files are in:

  • /home/vhost/WWW/campus-24.com/sites/default/files/js
  • /home/vhost/WWW/campus-24.com/sites/default/files/css
  • /home/vhost/WWW/campus-24.com/sites/default/files/imagecache
  • /home/vhost/WWW/campus-24.com/sites/default/files/ctools
  • /home/vhost/WWW/campus-24.com/sites/default/files/pictures

All the folders are empty. During the installation, I noticed warnings about too many files open.

I heard about the "css_1acaad3d96ebad99fc9b6ef9d4ee4.css" file: This is called an automatic generated file that compress all CSS styles used as to improve speed and help not overloading rendering. What if this file is missing in my folder? Does my site than have to look like the above mentioned site? I have not seen the following options: This is due to the fact in the performance administrative section (admin/settings/performance), in "Bandwidth optimizations" you have "Optimize CSS files" and "Optimize JavaScript files" enabled. These settings are normally very usefull for production (live) sites; for testing and customizing your Drupal Commons installation, it is better to disable them, and to have CSS and JavaScript development support with tools like Firebug.

Notes:

  • I have not seen where I can switch the options.
  • The original .htaccess file was changed by my server admin. I guess that I (and that means the site admin, my friend) miss, and have forgotten, an important option.

Now I found out how to see some overviews, and made a big step ahead; I have landed in the View activity_log_stream, displaying items of type Activity Log.

screenshot

I need some recommendations to figure out how to get some styles in the page.

$view = new view;
$view->name = 'activity_log_stream';
$view->description = 'Displays activity streams.';
$view->tag = '';
$view->view_php = '';
$view->base_table = 'activity_log_messages';
$view->is_cacheable = FALSE;
$view->api_version = 2;
$view->disabled = FALSE; /* Edit this to true to make a default view disabled initially */
$handler = $view->new_display('default', 'Defaults', 'default');
$handler->override_option('fields', array(
  'message' => array(
    'label' => '',
    'alter' => array(
      'alter_text' => 0,
      'text' => '',
      'make_link' => 0,
      'path' => '',
      'link_class' => '',
      'alt' => '',
      'prefix' => '',
      'suffix' => '',
      'target' => '',
      'help' => '',
      'trim' => 0,
      'max_length' => '',
      'word_boundary' => 1,
      'ellipsis' => 1,
      'html' => 0,
      'strip_tags' => 0,
    ),
    'empty' => '',
    'hide_empty' => 0,
    'empty_zero' => 0,
    'exclude' => 0,
    'id' => 'message',
    'table' => 'activity_log_messages',
    'field' => 'message',
    'relationship' => 'none',
  ),
));
$handler->override_option('sorts', array(
  'last_updated' => array(
    'order' => 'DESC',
    'granularity' => 'second',
    'id' => 'last_updated',
    'table' => 'activity_log_messages',
    'field' => 'last_updated',
    'relationship' => 'none',
  ),
));
$handler->override_option('arguments', array(
  'stream_owner_type' => array(
    'default_action' => 'ignore',
    'style_plugin' => 'default_summary',
    'style_options' => array(),
    'wildcard' => 'all',
    'wildcard_substitution' => 'All',
    'title' => '',
    'breadcrumb' => '',
    'default_argument_type' => 'activity_log_default_stream_owner_type',
    'default_argument' => '',
    'validate_type' => 'activity_log_validate_stream_owner_type',
    'validate_fail' => 'not found',
    'glossary' => 0,
    'limit' => '0',
    'case' => 'none',
    'path_case' => 'none',
    'transform_dash' => 0,
    'id' => 'stream_owner_type',
    'table' => 'activity_log_messages',
    'field' => 'stream_owner_type',
    'validate_user_argument_type' => 'uid',
    'validate_user_roles' => array(
      '2' => 0,
    ),
    'relationship' => 'none',
    'default_options_div_prefix' => '',
    'default_argument_fixed' => '',
    'default_argument_user' => 0,
    'default_argument_activity_log_stream_owner_type' => 'user',
    'default_argument_php' => '',
    'validate_argument_node_type' => array(
      'page' => 0,
    ),
    'validate_argument_node_access' => 0,
    'validate_argument_nid_type' => 'nid',
    'validate_argument_vocabulary' => array(
      '1' => 0,
    ),
    'validate_argument_type' => 'tid',
    'validate_argument_transform' => 0,
    'validate_user_restrict_roles' => 0,
    'validate_argument_php' => '',
  ),
  'stream_owner_id' => array(
    'default_action' => 'ignore',
    'style_plugin' => 'default_summary',
    'style_options' => array(),
    'wildcard' => 'all',
    'wildcard_substitution' => 'All',
    'title' => '',
    'breadcrumb' => '',
    'default_argument_type' => 'current_user',
    'default_argument' => '',
    'validate_type' => 'none',
    'validate_fail' => 'not found',
    'break_phrase' => 0,
    'not' => 0,
    'include' => array(
      'og' => 0,
      'ur' => 0,
    ),
    'id' => 'stream_owner_id',
    'table' => 'activity_log_messages',
    'field' => 'stream_owner_id',
    'validate_user_argument_type' => 'uid',
    'validate_user_roles' => array(
      '2' => 0,
    ),
    'relationship' => 'none',
    'default_options_div_prefix' => '',
    'default_argument_fixed' => '',
    'default_argument_user' => 0,
    'default_argument_activity_log_stream_owner_type' => 'user',
    'default_argument_php' => '',
    'validate_argument_node_type' => array(
      'page' => 0,
    ),
    'validate_argument_node_access' => 0,
    'validate_argument_nid_type' => 'nid',
    'validate_argument_vocabulary' => array(
      '1' => 0,
    ),
    'validate_argument_type' => 'tid',
    'validate_argument_transform' => 0,
    'validate_user_restrict_roles' => 0,
    'validate_argument_php' => '',
  ),
));
$handler->override_option('filters', array(
  'display_type' => array(
    'operator' => '=',
    'value' => 'web',
    'group' => '0',
    'exposed' => FALSE,
    'expose' => array(
      'operator' => FALSE,
      'label' => '',
    ),
    'id' => 'display_type',
    'table' => 'activity_log_templates',
    'field' => 'display_type',
    'relationship' => 'none',
  ),
));
$handler->override_option('access', array(
  'type' => 'perm',
  'perm' => 'view all activity messages',
));
$handler->override_option('cache', array(
  'type' => 'none',
));
$handler->override_option('empty', 'There are no visible status updates.');
$handler->override_option('empty_format', '1');
$handler->override_option('use_ajax', TRUE);
$handler->override_option('items_per_page', 20);
$handler->override_option('use_pager', '1');
$handler = $view->new_display('page', 'Page', 'page_1');
$handler->override_option('path', 'activities');
$handler->override_option('menu', array(
  'type' => 'normal',
  'title' => 'Activity stream',
  'description' => 'Displays activity streams.',
  'weight' => '0',
  'name' => 'navigation',
));
$handler->override_option('tab_options', array(
  'type' => 'none',
  'title' => '',
  'description' => '',
  'weight' => 0,
  'name' => 'navigation',
));
$handler = $view->new_display('page', 'Page', 'page_2');
$handler->override_option('path', '');
$handler->override_option('menu', array(
  'type' => 'none',
  'title' => '',
  'description' => '',
  'weight' => 0,
  'name' => 'navigation',
));
$handler->override_option('tab_options', array(
  'type' => 'none',
  'title' => '',
  'description' => '',
  'weight' => 0,
  'name' => 'navigation',
));

Update: On a quick step I did toggle the CSS-aggregation, and switched it off.

Just have a closer look at this, here:

Your lack of styles on the site is due to inadequate file permissions on your server. Your site is unable to save the auto-generated compressed CSS file, thus there is no style information to be displayed. Installing a different theme would do nothing to fix this situation. If you cannot manage to get the proper files permissions set up, you may try disabling CSS aggregation by navigating to Administration -> Site Configuration -> Performance, and toggling off the CSS aggregation setting, then clicking the save button. This will have a negative impact on the site's performance (speed of loading pages, etc.) and I would strongly recommend that you fix the underlying issue (file permissions) permanently before launching a live site so that you can re-enable CSS aggregation!

See the very first result of configuring accordingly.

screenshot

See the very same issue described here. The suggestion is to convert some files to UTF-8, but which specific files should I need to change to UTF-8?

  • h kiamlaluno - many thx for your great work here. and for the comments, replies and the editing, you do a superb job. well after 4 weeks i finally have found the above mentioned hints that helped me to fix the issue. well to toggle the css-aggregation is called to be a quick - rough - hack. i should have to talk to my server-admin that he carefully sets the chmods chowns of the files and folders - especially of those in the path sites/default/files - note:there the user wwwrun appeared in the last 4 weeks and thererfore i had troubles with the read of all content there... thx to you again – zero Jan 20 '12 at 2:48
2

I can't tell you what the problem is, but there are some things you can do to debug this. First things that come to my mind are:

  1. Check the status report (/admin/reports/status) and recent log messages (/admin/reports/dblog) to see if everything is OK. You may find that the file system is not writable; in that case, modify the permissions on your file folder (on Linux it's usually chmod -R 777 sites/default/files).
  2. If you think it's caused by the .htaccess file, try if replacing the original .htaccess solves the problem. If it does, apply the needed changes one by one and see when it breaks.
  3. Check the PHP/Apache error logs (assuming that you're on a Apache web server) for clues.
  • hi marcvangend thx i do as adviced and come bakd to report all the findings -thx so far! – zero Jan 13 '12 at 11:15
  • hello dear friends i have added some updates - see above... if you want to have access to adminarea just lemme know! i think that this goes over my head – zero Jan 18 '12 at 0:57
  • hi marvangend - many thx for your great work here. and for the comments, replies and the editing, you do a superb job. well after 4 weeks i finally have found the above mentioned hints that helped me to fix the issue. well to toggle the css-aggregation is called to be a quick - rough - hack. i should have to talk to my server-admin that he carefully sets the chmods chowns of the files and folders - especially of those in the path sites/default/files - note:there the user wwwrun appeared in the last 4 weeks and thererfore i had troubles with the read of all content there... thx to you again – – zero Jan 20 '12 at 2:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.