0

I'm having hard time integrating Entity Translation module with tags (Taxonomy and TagClouds modules). I want the following:

  • Cloud of tags to be showed on the site
  • Tags must be translatable, i.e. each tag must be showed in English or Russian, depending on the current language.

There are at least two problems. The first is that ET module breaks TagClouds. More specifically, whenever I enable these two modules (in any order), showed cloud of tags disappears. What is more suprisingly, it even doesn't matter was translation of tags enabled in ET module or not ( admin/config/regional/entity_translation -> translatable entity types -> taxonomy term) -- cloud of tags always ends up disappeared. Dblog doesn't show any errors. Is there any other place I can check for them?

The second problem is that if I make taxonomy term translatable in ET, I get strange errors when I'm trying to translate terms. For example:

  • If I get to the page of some tag created before enabling ET, for exampleen/taxonomy/term/8, than click Translate tab, I will see that current name is not English nor Russian. If click add button in either language, I will get not found error -- see screenshots. tag page not found error
    • If I click to edit button in list of tags (admin/structure/taxonomy/tags), I will get even more interesting error -- Access denied, You are not authorized to access this page.
    • Finally, If I click add items on some vocabulary and save it, I will get the following exception: Exception: Invalid translation language in EntityTranslationDefaultHandler->setTranslation() (line 635 of /var/www/drupal/sites/all/modules/entity_translation/includes/translation.handler.inc).

Name and Description fields of tags are marked as translatable (admin/structure/taxonomy/tags/fields/name_field -> Field translation Users may translate all occurrences of this field: Name in Теги)

What I am doing wrong?

Drupal version is 7, all modules are up to date. I also use i18n modules for translating the interface, by the way.

1

The exception can be fixed by visiting the following page: 'admin/config/regional/entity_translation'.

Then make sure that under the vertical tab 'taxonomy term' and the fieldset of your vocabulary the following is unchecked: 'Hide language selector'.

You may need to check 'Exclude Language neutral from the available languages' if that doesn't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.