6

In D8 I have a node with several translations - not all translations will be ready to publish at the same time. If I unpublish one translation it unpublishes all transaltions and default translation. Is this a bug or do I have an incorrect setting somewhere?

1 Answer 1

3

First of all lets make sure you have set up Drupal correctly:

  • Do you have activated the core Content translation module
  • Do you have activated the core Language module
  • Do you have set up at least 2 or more languages (of course you have)
  • Do you have set up detection and selection correctly (I think you have)
  • Do you have set up content types correctly to allow multiple languages (sure otherwise it won't work)
  • Now when you start to list your nodes in content/admin overview you should be able to select translate each node
  • If you choose this and you translate it you should see the button below saying translate and publish which can be switched to translate and unpublish this selection
  • if you choose the second your translation will not be published automatically. Violá

Hope it helps ...

5
  • Thanks for the reply @frank-theissner, What I see at is save and keep unpublished (all languages) Now I think I may have a wrong setting somewhere that could be causing the (all languages) settings to be the only options - any idea what it could be?
    – Janey
    Apr 7, 2016 at 13:44
  • oi67.tinypic.com/11id6ah.jpg this is how it looks here. I'm wondering how it comes to the option to save all languages. Is there another module interfering this behaviour? Apr 7, 2016 at 17:39
  • 5
    For step 5, make sure you set up the content types at /admin/config/regional/content-language, and make sure that all the fields, specifically including the publication status are marked as translatable.
    – Berdir
    Apr 7, 2016 at 19:27
  • @Berdir that was exactly my problem, I never had publish status set as translatable. Thanks for pointing that out.
    – Janey
    Apr 26, 2016 at 8:29
  • @Berdir Thanks for the tip, that was also my issue
    – Zuhair
    Dec 15, 2020 at 8:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.