2

I tried to install Drupal 7.10, and when the installation has done 28/29 modules, an error occured:

An AJAX HTTP error occurred.
HTTP Result Code: 200
Debugging information follows.
Path: http://localhost/drupal/install.php?profile=standard&locale=en&id=1&op=do
StatusText: OK
ResponseText: ( ! )
Fatal error: Maximum execution time of 30 seconds exceeded in C:\wamp\www\drupal\includes\database\mysql\database.inc on line 153
Call Stack:

Time Memory Function Location  
10.0004371192     {main}()                             ..\install.php:0
20.0043834504     install_drupal()                     ..\install.php:26
30.95958976424    install_run_tasks()                  ..\install.core.inc:79
41.929419997120   install_run_task()                   ..\install.core.inc:342
51.930720117440   _batch_page()                        ..\install.core.inc:452
61.931520124560   _batch_do()                          ..\batch.inc:80
71.931520124560   _batch_process()                     ..\batch.inc:161
81.933320214776   call_user_func_array()               ..\batch.inc:284
91.933320214800   _install_module_batch()              ..\batch.inc:284
101.933320215000  module_enable()                      ..\install.core.inc:1538
112.990422114008  module_invoke()                      ..\module.inc:448
122.990422114224  call_user_func_array()               ..\module.inc:794
132.990422114360  standard_install()                   ..\module.inc:794
1420.519725138960 user_role_grant_permissions()        ..\standard.install:400
1529.936125151208 MergeQuery->execute()                ..\user.module:3030
1629.938825159880 DatabaseTransaction->__destruct()    ..\user.module:3030
1729.938825159880 DatabaseConnection->popTransaction() ..\database.inc:1872
1829.938825159912 DatabaseConnection_mysql->popCommittableTransactions() ..\database.inc:1105

Can anyone help me to fix it?

5

The problem is the maximum execution time being exceeded. To fix this, you should change the maximum execution time in your php.ini file. Click on the Wamp icon on the taskbar, select PHP -> php.ini, find "max_execution_time" and change it from 30 to like 100-300, to make sure even the slower scripts get their job done before the timeout.

Remember to restart the server after you change the settings.

| improve this answer | |
  • i checked and change it to 200, but it still displayed: Maximum execution time of 30 seconds exceeded – Leo Lerdorf Jan 14 '12 at 19:22
  • 1
    Did you restart all services? – Madis Jan 14 '12 at 19:26
0

I was also getting the similar kind of error, during drupal installation, with response text "Drupal already installed". I fixed it by making below changes in php.ini,

max_execution_time = 180

max_input_time = 180

max_input_nesting_level = 300

memory_limit = 512M

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.