2

I'm using CK Editor to insert a table into my content (Body field).

I would like to set a background color, so I extended the style="width:100%" to be style="background-color: #FFEEE4; color: black;width: 100%". And this by clicking on Switch to plain text editor.

But now, once I save, the background-color style disappears again (Test Format FULL HTML). How can I make it stick?

1

go to:

/admin/config/content/ckeditor/edit/Advanced (for Filter HTML)

/admin/config/content/ckeditor/edit/Full (for Full HTML)

Then under Advanced Content Filter, select disabled.

enter image description here

If the above does not do it, depending on which one you are using (filter or full html) You need to go to

/admin/config/content/formats/filtered_html

OR

/admin/config/content/formats/full_html

Uncheck the correct faulty and chopped off html box.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.