0

I am working on Drupal 7.43.

I have created a few months ago standard fields (text) with unlimited values. Everything was fine.

Today, I can not add another item, the Javascript icon is turning and then nothing happens. Surprisingly, it works on a local version. The weirdest thing is when I use a fresh field, created for test, everything works fine and I can have multiple values added.

In recent log messages, I have an AJAX warning : Invalid form POST data. (EDIT : this warning message is not displayed each time I try to add another item.)

I have tried many different things (jQuery Update configuration, new theme, deactivation/reactivation of modules, cache flushing...).

Does anyone know if I could fix my "broken fields" so I can still use them instead of creating new ones and cloning all the values already entered? Thanks in advance.

A similar issue here

EDIT (05/09/16) :

Looking at the Firebug Console, in JSON tab, I have just noticed that 2 lines are missing, compared to my localhost version, where the function works fine. The lines missing :

  • Object {command="add_css"...}
  • Object {command="insert", method="prepend", selector="head"...}.

Seems important? Any way to get these lines on the production website?

  • so you're using fieldgroups ?? do you have an javascript error ? – rémy Apr 18 '16 at 13:32
  • Indeed, these fields are included in Field Groups and I get an Ajax error in log messages : Invalid form POST data (sorry, I forgot to mention it, I edit the question). I have tried to move a field outside the Field Group and the issue was still there. A new field test included in a Field Group is working though... – Toki Apr 18 '16 at 15:22
  • Any idea about this issue? Thanks for any tip. – Toki Apr 22 '16 at 13:03
  • Check to make sure you code matches between you test and productions. Sometimes people miss a few files if they aren't using git or svn to manage the code on production (and sometimes even if they are). – acrosman May 9 '16 at 17:03
  • Thanks for your comment. I have compared many things using Filezilla tools and Firebug and no obvious differences appear. I am a site builder so I did not modify the Drupal core code. As I mentioned before, when I create a new multi-value field on the production site, everything works fine. It seems like the original multi-value fields are "broken" or modified. Does anyone encounter that kind of issue before? Could it be jQuery update module or the PHP version (test site works with 5.6, production with 5.4)? – Toki May 10 '16 at 13:44
0

After many different tests, I have found the solution.

All the multi-value core fields using the module "Better Field Descriptions" were broken.

The help text added below by this module seemed to block the new option line to be created or at least displayed. Deactivate the module fixed the problem.

So, if you need a multiple values field and a permission to edit the help texts, be cautious with module interactions.

Thanks for those who tried to help me on this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.