0

I am using Commerce Stripe as the payment gateway on my website.

Everything is configured properly, and but still while checkout I am getting this error:

"Error making the payment. Please contact shop admin to proceed."

When I checked my recent logs I found this warning there:

Commerce Stripe is currently tested with stripe-php library versions 1.17.1 through 1.18.0. You are using version 3.12.1, and you should downgrade.

Do anyone have any idea, what the issue is??

  • The message is telling you the library is not the version for which the module has been tested. Your library is version 3.12.1, while the module requires a version that is not more than 1.18.0. – kiamlaluno Apr 29 '16 at 10:59
  • I have downloaded version v1.18.0(link for this version only was given on module's page) only, and kept it into the libraries folder(as suggested on the modules page) – Dev Apr 29 '16 at 12:07
  • I tried to apply a patch I got from the drupal org, but that too failed giving fatal error to the website on checkout, I removed the patch immediately afterwards, tried to checkout a few times. Do not know how but it started working. Need to move the changes to production, but not getting what made it work, as I had undone the patch with ctrl+z. – Dev Apr 29 '16 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.