0

Summary
In Panelizer, I have created one Panel. In Content for this panel there is an image field. I can find no option to change the image style.

From Manage Display in the content type, I am able to select Image Style for various display settings but this makes no difference to the image in the Panel in Panelizer.

Where am I not looking?

Details
In Panelizer for Content Type = (Person), first row on the left "Full Page override" I clicked "Panelize" and "Provide Default Panel". I think I have created one Panel. In the Content for this panel, I have placed an image field (field_person_image) in the right column.

In Panelizer on R of field_person_image is a gear listing- -"Settings". Formatter options for can select This Node, override title, change label position. There is an option for "Select a formatter" but the only option is "Image". There is no option to change the image style.
-Style which offers Pane Style for this node (rounded corners) -Visibility rules -Locking -Caching

In Structure > Content Type > Person > Manage Display, I am able to select Image Style for various display settings. Changing from Large to Medium to Small (using Default, Full Content) makes no difference to the image in the Default Panel in Panelizer.

This similar sounding question also has no answer. Using Image 7.43. There are no results at Issues for Drupal Core (Drupal.org) about Panelizer and image formatting.

What am I missing?

0

Although I could swear that I had done this before, I deleted the image in the panel. This time, when I added the image back into the panel, I got image formatter options. Which I set, and the node behaved correctly.

Despite the frustratingly long time I worked on this, it was a non-problem!

AMENDMENT: When the panel is first created and saved, all of the fields appear in the panel. If the image field is left as is, there are no formatter options. However, if the image field is deleted from the panel and then re-added, then the formatter options appear. This is noteworthy, I think.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.