1

I get following two warnings:

Due to the settings for ServerTokens in httpd.conf, it is impossible to accurately determine the version of Apache running on this server. The reported value is Apache, to run Drupal without mod_rewrite, a minimum version of 2.2.16 is needed.

 

PHP OPcode caching can improve your site's performance considerably. It is highly recommended to have OPcache installed on your server.

It would be nice if someone could help me with some pointers about how to solve this problem.

2

The first error message is saying that, basing on headers returned from Apache, Drupal is not able to determine which Apache version the server is using. If you have access to the httpd.conf file, you can set ServerTokens to at least ServerTokens Min, so Drupal will be able to check which Apache version the server is using.
If you know your server is using at least Apache 2.2.16, you can go forward and proceed with the installation. What you are getting is just a warning for you to check the Apache version, since Drupal cannot find out that.

The other message is telling you that it should preferable to install the OPcache extensions, which means you need to have access to the php.ini file, and being able to install extensions on your server.
If you aren't able to do that, don't do anything. That is not an error message, but a warning message telling you it is preferable to have OPcache enabled to make Drupal faster, but Drupal 8 works also without it.

|improve this answer|||||
  • Thank you @kiamlaluno. I edited /etc/apache2/sysconfig.d/global.conf ServerTokens Min as you suggested and that solved the problem. For the opcache configuration I refered myself to this page link. You've been very helpful – Jorge Montoya Apr 30 '16 at 23:54
0

For me editing /etc/apache2/sysconfig.d/global.conf didn't work because global.conf gets overwritten when Apache2 is re-started, and apache needs to be re-started for the change to take effect. To overcome this I found I needed to edit the file '/etc/sysconfig/apache2' the line 247;

APACHE_SERVERTOKENS="ProductOnly"

becomes

APACHE_SERVERTOKENS="Min"

Then re-start your apache server and /etc/apache2/sysconfig.d/global.conf should be overwritten as required. Hope this helps.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.