1

I am trying to create a rule that will send an email to a list of webform submissions, notifying them when new content is created. So far, here's what I have:

Event: after saving new content of type [type]

Conditions: content is of type

Actions: Using a Rules view display, I'm grabbing the webform submissions, and then looping through to send mail to the value of the webform submissions.

All works well, until I need to send the mail. Rather than looping through and sending to the email addresses that I'm trying to get from the webform submissions, it appears to be sending to the submission ID instead.

I'm sure there's something I'm missing in either my rules view display, or the rule itself, but I've hit a wall. Anyone know what I might be doing wrong?

0

To make this work, you should process the results of a VBO enabled view via Rules, whereas your rule performs 2 Rules Actions:

  • load the VBO list of webform submissions that you want to be processed.
  • add a loop to perform a Rules Action, for each webform submissions contained in your Views results.

Since you want this Rules Action to be "... sending to the email addresses ...", you need to make sure that these email addresses are contained in the Views result (if needed enhance you view to have them included).

For more details, have a look at the tutorial "How to process the results of a VBO enabled view via Rules?".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.