1

Had a strange issue today where I have a sub-theme (bootstrap) called 'rrre_theme'. I can confirm I have not made any errors throughout my sub-theme in terms of naming. I position blocks and generally go about drupal business. When it comes time to export my config i run drush cex vcs where vcs is a default config directory defined in my settings.php. So far so standard. However I am noticing that config-export is changing the name of my theme. Here is an example git diff on a config file after i have run cex:

diff --git a/config/default/block.block.propertystyle.yml
b/config/default/block.block.propertystyle.yml
index 1351c6b..363abda 100644
--- a/config/default/block.block.propertystyle.yml
+++ b/config/default/block.block.propertystyle.yml
@@ -1,4 +1,4 @@
-uuid: 211de5b8-0385-4d83-b57d-d965abe2df8e
+uuid: 7f3fedfd-098d-4fe6-ad74-ac056c64627d
langcode: en
status: true
dependencies:
@@ -7,11 +7,11 @@ dependencies:
   module:
     - facets
   theme:
-    - rrre_theme
+    - rrre
 id: propertystyle
-theme: rrre_theme
+theme: rrre
 region: content
-weight: -7
+weight: -3
 provider: null
 plugin: 'facet_block:propertystyle'
 settings:
@@ -22,7 +22,7 @@ settings:
 visibility:
  other_facet:

You can see that the post cex file has changed my theme name?!

Can anyone explain why this is the case? In the meantime I have renamed my theme to: rrretheme and will report back here if that fixes it.

  • Just a shot in the dark, I wonder if naming a theme with _theme is a reserved word of some sort if there is such a thing? – Danny Englander May 6 '16 at 17:33
  • 1
    Yes I wonder if it's a bug? Either way renaming the theme as I described has worked. I will try and write a test for this and submit issue to core. Will leave an answer if that works out. – iain maitland May 6 '16 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.