0

i'm using drupal 7 and superfish 7.x-1.9, the problem is when i reduce the browser, the menu is not responsive, it still be the same nothing moves, i'm working on it for hours now and nothing

Please any help on configurations ?

Here a screenshot of the desktop menu : enter image description here

And here the same menu with browser reduced on width : enter image description here

4
  • Hide it for mobile and show a mobile menu for mobile May 10, 2016 at 19:27
  • @J.Reynolds This is exactly what i want to do(keeping the desktop and hide it for mobile AND create a second menu for mobile that is hidden on desktop), but superfish is supposed to be responsive by default, but not for the menu i've created
    – Sushi
    May 11, 2016 at 8:06
  • I don't see anything in the documentation about it being responsive. When I used it in the past I made the text and padding smaller at various breakpoints, then hid it completely at mobile breakpoint. Looj here for alternative: drupal.org/project/responsive_dropdown_menus May 11, 2016 at 9:19
  • Yes I see @J.Reynolds but from the superfish 2.0 the menu is responsive, so for my version i'm gonna work with custom breakpoints as you said
    – Sushi
    May 11, 2016 at 9:27

1 Answer 1

1

Superfish has a pretty extensive settings/configuration area, all of which, do take away any necessary programming for menus, and make setting up a complex menu simple.

You are probably missing a mobile declaration somewhere in the settings/config, I would read up on the Superfish documentation here: https://www.drupal.org/node/754652

This also has other useful links that may assist with your situation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.