2

I created a view with an RSS feed on my D7 site. From the XML feed I'd like to remove the author who created the node displayed in my view and the creation date. I've searched everywhere and tried everything, but I can't seem to remove these two fields from my feed.

I only have permissions to work in views so if you have a solution using Views 3 I'd be most appreciative.

Thank you!

1

You can specify under "Manage Display" how the content you want to feed will look in the "RSS" (or any other) viewmode. By default, you only have the body (or any additional fields) available. To have more control over what's displayed in which viewmode, you can use the Display Suite module. This module allows you (among many other features) to use another layout for this content. By enabling a layout on the viewmode you like, you also get additional fields like for example the Author and the Post date which you then can enable or disable.

  • Do I need to have Display Suite installed/enabled in order to change my view with "Manage Display"? I don't see Manage Display in my RSS view so I'm assuming yes. Just want confirmation. Thank you for the quick and helpful reply. – Meliss Jan 18 '12 at 21:04
  • Ok - just confirmed that I do have Display Suite installed and enabled on the site. How do I 1) configure it to work with an feed w/in a view and 2) use it in the feed view? Sorry, but I haven't worked with D7 before... – Meliss Jan 18 '12 at 21:10
  • Just go to your content type and click on "Manage Display". Then enable the RSS viewmode on "Custom display settings". Then select a layout (one column for example) and drag the fields around. – Lance Jan 18 '12 at 21:29
  • The Content Type edit pages are under the Stucture section of the admin pages -you can't change these display setting from your View editing page (just to be clear). – geerlingguy Jan 18 '12 at 23:01
  • Thanks for the tips. I'm giving everything a try now and will let you know how things go. – Meliss Jan 19 '12 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.